openSUSE Security Update: Security update for krb5
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2020:2062-1
Rating:             moderate
References:         #1178512 
Cross-References:   CVE-2020-28196
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for krb5 fixes the following security issue:

   - CVE-2020-28196: Fixed an unbounded recursion via an ASN.1-encoded
     Kerberos message (bsc#1178512).

   This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2020-2062=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      krb5-1.16.3-lp152.5.13.1
      krb5-client-1.16.3-lp152.5.13.1
      krb5-client-debuginfo-1.16.3-lp152.5.13.1
      krb5-debuginfo-1.16.3-lp152.5.13.1
      krb5-debugsource-1.16.3-lp152.5.13.1
      krb5-devel-1.16.3-lp152.5.13.1
      krb5-mini-1.16.3-lp152.5.13.1
      krb5-mini-debuginfo-1.16.3-lp152.5.13.1
      krb5-mini-debugsource-1.16.3-lp152.5.13.1
      krb5-mini-devel-1.16.3-lp152.5.13.1
      krb5-plugin-kdb-ldap-1.16.3-lp152.5.13.1
      krb5-plugin-kdb-ldap-debuginfo-1.16.3-lp152.5.13.1
      krb5-plugin-preauth-otp-1.16.3-lp152.5.13.1
      krb5-plugin-preauth-otp-debuginfo-1.16.3-lp152.5.13.1
      krb5-plugin-preauth-pkinit-1.16.3-lp152.5.13.1
      krb5-plugin-preauth-pkinit-debuginfo-1.16.3-lp152.5.13.1
      krb5-server-1.16.3-lp152.5.13.1
      krb5-server-debuginfo-1.16.3-lp152.5.13.1

   - openSUSE Leap 15.2 (x86_64):

      krb5-32bit-1.16.3-lp152.5.13.1
      krb5-32bit-debuginfo-1.16.3-lp152.5.13.1
      krb5-devel-32bit-1.16.3-lp152.5.13.1


References:

   https://www.suse.com/security/cve/CVE-2020-28196.html
   https://bugzilla.suse.com/1178512
_______________________________________________
openSUSE Security Announce mailing list -- [email protected]
To unsubscribe, email [email protected]
List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette
List Archives: https://lists.opensuse.org/archives/list/[email protected]