Discover Government News


   openSUSE Security Update: Security update for mariadb
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2020:2090-1
Rating:             moderate
References:         #1175596 #1177472 #1178428 
Cross-References:   CVE-2020-14765 CVE-2020-14776 CVE-2020-14789
                    CVE-2020-14812 CVE-2020-15180
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes 5 vulnerabilities is now available.

Description:

   This update for mariadb and mariadb-connector-c fixes the following issues:

   - Update mariadb to 10.2.36 GA [bsc#1177472, bsc#1178428] fixing for the
     following security vulnerabilities: CVE-2020-14812, CVE-2020-14765,
     CVE-2020-14776, CVE-2020-14789 CVE-2020-15180

   - Update mariadb-connector-c to 3.1.11 [bsc#1177472 and bsc#1178428]

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2020-2090=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      libmariadb-devel-3.1.11-lp152.2.3.1
      libmariadb-devel-debuginfo-3.1.11-lp152.2.3.1
      libmariadb3-3.1.11-lp152.2.3.1
      libmariadb3-debuginfo-3.1.11-lp152.2.3.1
      libmariadb_plugins-3.1.11-lp152.2.3.1
      libmariadb_plugins-debuginfo-3.1.11-lp152.2.3.1
      libmariadbprivate-3.1.11-lp152.2.3.1
      libmariadbprivate-debuginfo-3.1.11-lp152.2.3.1
      libmysqld-devel-10.2.36-lp152.2.6.1
      libmysqld19-10.2.36-lp152.2.6.1
      libmysqld19-debuginfo-10.2.36-lp152.2.6.1
      mariadb-10.2.36-lp152.2.6.1
      mariadb-bench-10.2.36-lp152.2.6.1
      mariadb-bench-debuginfo-10.2.36-lp152.2.6.1
      mariadb-client-10.2.36-lp152.2.6.1
      mariadb-client-debuginfo-10.2.36-lp152.2.6.1
      mariadb-connector-c-debugsource-3.1.11-lp152.2.3.1
      mariadb-debuginfo-10.2.36-lp152.2.6.1
      mariadb-debugsource-10.2.36-lp152.2.6.1
      mariadb-galera-10.2.36-lp152.2.6.1
      mariadb-test-10.2.36-lp152.2.6.1
      mariadb-test-debuginfo-10.2.36-lp152.2.6.1
      mariadb-tools-10.2.36-lp152.2.6.1
      mariadb-tools-debuginfo-10.2.36-lp152.2.6.1

   - openSUSE Leap 15.2 (x86_64):

      libmariadb3-32bit-3.1.11-lp152.2.3.1
      libmariadb3-32bit-debuginfo-3.1.11-lp152.2.3.1

   - openSUSE Leap 15.2 (noarch):

      mariadb-errormessages-10.2.36-lp152.2.6.1


References:

   https://www.suse.com/security/cve/CVE-2020-14765.html
   https://www.suse.com/security/cve/CVE-2020-14776.html
   https://www.suse.com/security/cve/CVE-2020-14789.html
   https://www.suse.com/security/cve/CVE-2020-14812.html
   https://www.suse.com/security/cve/CVE-2020-15180.html
   https://bugzilla.suse.com/1175596
   https://bugzilla.suse.com/1177472
   https://bugzilla.suse.com/1178428
_______________________________________________
openSUSE Security Announce mailing list -- security-announce@lists.opensuse.org
To unsubscribe, email security-announce-leave@lists.opensuse.org
List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette
List Archives: https://lists.opensuse.org/archives/list/security-announce@lists.opensuse.org/

openSUSE: 2020:2090-1 moderate: mariadb

November 28, 2020
An update that fixes 5 vulnerabilities is now available

Description

This update for mariadb and mariadb-connector-c fixes the following issues: - Update mariadb to 10.2.36 GA [bsc#1177472, bsc#1178428] fixing for the following security vulnerabilities: CVE-2020-14812, CVE-2020-14765, CVE-2020-14776, CVE-2020-14789 CVE-2020-15180 - Update mariadb-connector-c to 3.1.11 [bsc#1177472 and bsc#1178428] This update was imported from the SUSE:SLE-15:Update update project.

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2020-2090=1


Package List

- openSUSE Leap 15.2 (i586 x86_64): libmariadb-devel-3.1.11-lp152.2.3.1 libmariadb-devel-debuginfo-3.1.11-lp152.2.3.1 libmariadb3-3.1.11-lp152.2.3.1 libmariadb3-debuginfo-3.1.11-lp152.2.3.1 libmariadb_plugins-3.1.11-lp152.2.3.1 libmariadb_plugins-debuginfo-3.1.11-lp152.2.3.1 libmariadbprivate-3.1.11-lp152.2.3.1 libmariadbprivate-debuginfo-3.1.11-lp152.2.3.1 libmysqld-devel-10.2.36-lp152.2.6.1 libmysqld19-10.2.36-lp152.2.6.1 libmysqld19-debuginfo-10.2.36-lp152.2.6.1 mariadb-10.2.36-lp152.2.6.1 mariadb-bench-10.2.36-lp152.2.6.1 mariadb-bench-debuginfo-10.2.36-lp152.2.6.1 mariadb-client-10.2.36-lp152.2.6.1 mariadb-client-debuginfo-10.2.36-lp152.2.6.1 mariadb-connector-c-debugsource-3.1.11-lp152.2.3.1 mariadb-debuginfo-10.2.36-lp152.2.6.1 mariadb-debugsource-10.2.36-lp152.2.6.1 mariadb-galera-10.2.36-lp152.2.6.1 mariadb-test-10.2.36-lp152.2.6.1 mariadb-test-debuginfo-10.2.36-lp152.2.6.1 mariadb-tools-10.2.36-lp152.2.6.1 mariadb-tools-debuginfo-10.2.36-lp152.2.6.1 - openSUSE Leap 15.2 (x86_64): libmariadb3-32bit-3.1.11-lp152.2.3.1 libmariadb3-32bit-debuginfo-3.1.11-lp152.2.3.1 - openSUSE Leap 15.2 (noarch): mariadb-errormessages-10.2.36-lp152.2.6.1


References

https://www.suse.com/security/cve/CVE-2020-14765.html https://www.suse.com/security/cve/CVE-2020-14776.html https://www.suse.com/security/cve/CVE-2020-14789.html https://www.suse.com/security/cve/CVE-2020-14812.html https://www.suse.com/security/cve/CVE-2020-15180.html https://bugzilla.suse.com/1175596 https://bugzilla.suse.com/1177472 https://bugzilla.suse.com/1178428openSUSE Security Announce mailing list -- security-announce@lists.opensuse.orgTo unsubscribe, email security-announce-leave@lists.opensuse.orgList Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquetteList Archives: https://lists.opensuse.org/archives/list/security-announce@lists.opensuse.org/


Severity
Announcement ID: openSUSE-SU-2020:2090-1
Rating: moderate
Affected Products: openSUSE Leap 15.2 .

Related News