openSUSE Security Update: Security update for mariadb
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2020:2254-1
Rating:             important
References:         #1177472 #1178428 
Cross-References:   CVE-2020-14765 CVE-2020-14776 CVE-2020-14789
                    CVE-2020-14812 CVE-2020-15180
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes 5 vulnerabilities is now available.

Description:

   This update for mariadb fixes the following issues:

   Update to 10.4.17 [bsc#1177472] and [bsc#1178428]

   - fixing for the following security vulnerabilities: CVE-2020-14812,
     CVE-2020-14765, CVE-2020-14776, CVE-2020-14789, CVE-2020-15180

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2020-2254=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      libmariadbd-devel-10.4.17-lp152.2.8.1
      libmariadbd19-10.4.17-lp152.2.8.1
      libmariadbd19-debuginfo-10.4.17-lp152.2.8.1
      mariadb-10.4.17-lp152.2.8.1
      mariadb-bench-10.4.17-lp152.2.8.1
      mariadb-bench-debuginfo-10.4.17-lp152.2.8.1
      mariadb-client-10.4.17-lp152.2.8.1
      mariadb-client-debuginfo-10.4.17-lp152.2.8.1
      mariadb-debuginfo-10.4.17-lp152.2.8.1
      mariadb-debugsource-10.4.17-lp152.2.8.1
      mariadb-galera-10.4.17-lp152.2.8.1
      mariadb-rpm-macros-10.4.17-lp152.2.8.1
      mariadb-test-10.4.17-lp152.2.8.1
      mariadb-test-debuginfo-10.4.17-lp152.2.8.1
      mariadb-tools-10.4.17-lp152.2.8.1
      mariadb-tools-debuginfo-10.4.17-lp152.2.8.1

   - openSUSE Leap 15.2 (noarch):

      mariadb-errormessages-10.4.17-lp152.2.8.1


References:

   https://www.suse.com/security/cve/CVE-2020-14765.html
   https://www.suse.com/security/cve/CVE-2020-14776.html
   https://www.suse.com/security/cve/CVE-2020-14789.html
   https://www.suse.com/security/cve/CVE-2020-14812.html
   https://www.suse.com/security/cve/CVE-2020-15180.html
   https://bugzilla.suse.com/1177472
   https://bugzilla.suse.com/1178428
_______________________________________________
openSUSE Security Announce mailing list -- [email protected]g
To unsubscribe, email [email protected]
List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette
List Archives: https://lists.opensuse.org/archives/list/[email protected]