openSUSE Security Update: Security update for xen
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2020:2331-1
Rating:             moderate
References:         #1027519 #1176782 #1179496 #1179498 #1179501 
                    #1179502 #1179506 #1179514 #1179516 
Cross-References:   CVE-2020-29480 CVE-2020-29481 CVE-2020-29483
                    CVE-2020-29484 CVE-2020-29566 CVE-2020-29570
                    CVE-2020-29571
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that solves 7 vulnerabilities and has two fixes
   is now available.

Description:

   This update for xen fixes the following issues:

   - CVE-2020-29480: Fixed an issue which could have allowed leak of
     non-sensitive data to administrator guests (bsc#117949 XSA-115).
   - CVE-2020-29481: Fixed an issue which could have allowd to new domains to
     inherit existing node permissions (bsc#1179498 XSA-322).
   - CVE-2020-29483: Fixed an issue where guests could disturb domain cleanup
     (bsc#1179502 XSA-325).
   - CVE-2020-29484: Fixed an issue where guests could crash xenstored via
     watchs (bsc#1179501 XSA-324).
   - CVE-2020-29566: Fixed an undue recursion in x86 HVM context switch code
     (bsc#1179506 XSA-348).
   - CVE-2020-29570: Fixed an issue where FIFO event channels control block
     related ordering (bsc#1179514 XSA-358).
   - CVE-2020-29571: Fixed an issue where FIFO event channels control
     structure ordering (bsc#1179516 XSA-359).
   - Fixed an issue where dump-core shows missing nr_pages during core
     (bsc#1176782).
   - Multiple other bugs (bsc#1027519)

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2020-2331=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      xen-debugsource-4.13.2_06-lp152.2.21.1
      xen-devel-4.13.2_06-lp152.2.21.1
      xen-libs-4.13.2_06-lp152.2.21.1
      xen-libs-debuginfo-4.13.2_06-lp152.2.21.1
      xen-tools-domU-4.13.2_06-lp152.2.21.1
      xen-tools-domU-debuginfo-4.13.2_06-lp152.2.21.1

   - openSUSE Leap 15.2 (x86_64):

      xen-4.13.2_06-lp152.2.21.1
      xen-doc-html-4.13.2_06-lp152.2.21.1
      xen-libs-32bit-4.13.2_06-lp152.2.21.1
      xen-libs-32bit-debuginfo-4.13.2_06-lp152.2.21.1
      xen-tools-4.13.2_06-lp152.2.21.1
      xen-tools-debuginfo-4.13.2_06-lp152.2.21.1

   - openSUSE Leap 15.2 (noarch):

      xen-tools-xendomains-wait-disk-4.13.2_06-lp152.2.21.1


References:

   https://www.suse.com/security/cve/CVE-2020-29480.html
   https://www.suse.com/security/cve/CVE-2020-29481.html
   https://www.suse.com/security/cve/CVE-2020-29483.html
   https://www.suse.com/security/cve/CVE-2020-29484.html
   https://www.suse.com/security/cve/CVE-2020-29566.html
   https://www.suse.com/security/cve/CVE-2020-29570.html
   https://www.suse.com/security/cve/CVE-2020-29571.html
   https://bugzilla.suse.com/1027519
   https://bugzilla.suse.com/1176782
   https://bugzilla.suse.com/1179496
   https://bugzilla.suse.com/1179498
   https://bugzilla.suse.com/1179501
   https://bugzilla.suse.com/1179502
   https://bugzilla.suse.com/1179506
   https://bugzilla.suse.com/1179514
   https://bugzilla.suse.com/1179516
_______________________________________________
openSUSE Security Announce mailing list -- [email protected]
To unsubscribe, email [email protected]
List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette
List Archives: https://lists.opensuse.org/archives/list/[email protected]