openSUSE Security Update: Security update for gimp
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2020:2357-1
Rating:             important
References:         #1073628 #1178726 
Cross-References:   CVE-2017-17787
Affected Products:
                    openSUSE Leap 15.1
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for gimp fixes the following issues:

   Security issue fixed:

   - CVE-2017-17787: Fixed an out-of-bounds read in the PSP importer
     (bsc#1073628).

   Non-security issue fixed:

   - Fixed a software crash while importing a _PostScript_ file (bsc#1178726).

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.1:

      zypper in -t patch openSUSE-2020-2357=1



Package List:

   - openSUSE Leap 15.1 (i586 x86_64):

      gimp-2.8.22-lp151.5.6.1
      gimp-debuginfo-2.8.22-lp151.5.6.1
      gimp-debugsource-2.8.22-lp151.5.6.1
      gimp-devel-2.8.22-lp151.5.6.1
      gimp-devel-debuginfo-2.8.22-lp151.5.6.1
      gimp-plugin-aa-2.8.22-lp151.5.6.1
      gimp-plugin-aa-debuginfo-2.8.22-lp151.5.6.1
      gimp-plugins-python-2.8.22-lp151.5.6.1
      gimp-plugins-python-debuginfo-2.8.22-lp151.5.6.1
      libgimp-2_0-0-2.8.22-lp151.5.6.1
      libgimp-2_0-0-debuginfo-2.8.22-lp151.5.6.1
      libgimpui-2_0-0-2.8.22-lp151.5.6.1
      libgimpui-2_0-0-debuginfo-2.8.22-lp151.5.6.1

   - openSUSE Leap 15.1 (noarch):

      gimp-lang-2.8.22-lp151.5.6.1

   - openSUSE Leap 15.1 (x86_64):

      libgimp-2_0-0-32bit-2.8.22-lp151.5.6.1
      libgimp-2_0-0-32bit-debuginfo-2.8.22-lp151.5.6.1
      libgimpui-2_0-0-32bit-2.8.22-lp151.5.6.1
      libgimpui-2_0-0-32bit-debuginfo-2.8.22-lp151.5.6.1


References:

   https://www.suse.com/security/cve/CVE-2017-17787.html
   https://bugzilla.suse.com/1073628
   https://bugzilla.suse.com/1178726
_______________________________________________
openSUSE Security Announce mailing list -- [email protected]
To unsubscribe, email [email protected]
List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette
List Archives: https://lists.opensuse.org/archives/list/[email protected]