openSUSE Security Update: Security update for gimp
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0027-1
Rating:             moderate
References:         #1073624 #1073625 #1073626 
Cross-References:   CVE-2017-17784 CVE-2017-17785 CVE-2017-17786
                   
Affected Products:
                    openSUSE Leap 15.1
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for gimp fixes the following issues:

   - CVE-2017-17784: Fixed an insufficient string validation for input names
     (bsc#1073624).
   - CVE-2017-17785: Fixed an heap-based buffer overflow in FLI import
     (bsc#1073625).
   - CVE-2017-17786: Fixed an out-of-bounds read in TGA (bsc#1073626).

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.1:

      zypper in -t patch openSUSE-2021-27=1



Package List:

   - openSUSE Leap 15.1 (i586 x86_64):

      gimp-2.8.22-lp151.5.9.1
      gimp-debuginfo-2.8.22-lp151.5.9.1
      gimp-debugsource-2.8.22-lp151.5.9.1
      gimp-devel-2.8.22-lp151.5.9.1
      gimp-devel-debuginfo-2.8.22-lp151.5.9.1
      gimp-plugin-aa-2.8.22-lp151.5.9.1
      gimp-plugin-aa-debuginfo-2.8.22-lp151.5.9.1
      gimp-plugins-python-2.8.22-lp151.5.9.1
      gimp-plugins-python-debuginfo-2.8.22-lp151.5.9.1
      libgimp-2_0-0-2.8.22-lp151.5.9.1
      libgimp-2_0-0-debuginfo-2.8.22-lp151.5.9.1
      libgimpui-2_0-0-2.8.22-lp151.5.9.1
      libgimpui-2_0-0-debuginfo-2.8.22-lp151.5.9.1

   - openSUSE Leap 15.1 (noarch):

      gimp-lang-2.8.22-lp151.5.9.1

   - openSUSE Leap 15.1 (x86_64):

      libgimp-2_0-0-32bit-2.8.22-lp151.5.9.1
      libgimp-2_0-0-32bit-debuginfo-2.8.22-lp151.5.9.1
      libgimpui-2_0-0-32bit-2.8.22-lp151.5.9.1
      libgimpui-2_0-0-32bit-debuginfo-2.8.22-lp151.5.9.1


References:

   https://www.suse.com/security/cve/CVE-2017-17784.html
   https://www.suse.com/security/cve/CVE-2017-17785.html
   https://www.suse.com/security/cve/CVE-2017-17786.html
   https://bugzilla.suse.com/1073624
   https://bugzilla.suse.com/1073625
   https://bugzilla.suse.com/1073626