openSUSE Security Update: Security update for go1.14
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0190-1
Rating:             moderate
References:         #1164903 #1181145 #1181146 
Cross-References:   CVE-2021-3114 CVE-2021-3115
Affected Products:
                    openSUSE Leap 15.1
______________________________________________________________________________

   An update that solves two vulnerabilities and has one
   errata is now available.

Description:

   This update for go1.14 fixes the following issues:

   Go was updated to version 1.14.14 (bsc#1164903).

   Security issues fixed:

   - CVE-2021-3114: Fixed incorrect operations on the P-224 curve in
     crypto/elliptic (bsc#1181145).
   - CVE-2021-3115: Fixed a potential arbitrary code execution in the build
     process (bsc#1181146).

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.1:

      zypper in -t patch openSUSE-2021-190=1



Package List:

   - openSUSE Leap 15.1 (x86_64):

      go1.14-1.14.14-lp151.28.1
      go1.14-doc-1.14.14-lp151.28.1
      go1.14-race-1.14.14-lp151.28.1


References:

   https://www.suse.com/security/cve/CVE-2021-3114.html
   https://www.suse.com/security/cve/CVE-2021-3115.html
   https://bugzilla.suse.com/1164903
   https://bugzilla.suse.com/1181145
   https://bugzilla.suse.com/1181146