openSUSE Security Update: Security update for nodejs14
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0356-1
Rating:             important
References:         #1182619 #1182620 
Cross-References:   CVE-2021-22883 CVE-2021-22884
CVSS scores:
                    CVE-2021-22883 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-22884 (SUSE): 5.8 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:L

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for nodejs14 fixes the following issues:

   - New upstream LTS version 14.16.0:
     * CVE-2021-22883: HTTP2 'unknownProtocol' cause Denial of Service by
       resource exhaustion (bsc#1182619)
     * CVE-2021-22884: DNS rebinding in --inspect (bsc#1182620)

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-356=1



Package List:

   - openSUSE Leap 15.2 (noarch):

      nodejs14-docs-14.16.0-lp152.8.1

   - openSUSE Leap 15.2 (x86_64):

      nodejs14-14.16.0-lp152.8.1
      nodejs14-debuginfo-14.16.0-lp152.8.1
      nodejs14-debugsource-14.16.0-lp152.8.1
      nodejs14-devel-14.16.0-lp152.8.1
      npm14-14.16.0-lp152.8.1


References:

   https://www.suse.com/security/cve/CVE-2021-22883.html
   https://www.suse.com/security/cve/CVE-2021-22884.html
   https://bugzilla.suse.com/1182619
   https://bugzilla.suse.com/1182620