openSUSE Security Update: Security update for avahi
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0370-1
Rating:             moderate
References:         #1180827 
Cross-References:   CVE-2021-26720
CVSS scores:
                    CVE-2021-26720 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-26720 (SUSE): 3.6 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for avahi fixes the following issues:

   - CVE-2021-26720: drop privileges when invoking avahi-daemon-check-dns.sh
     (bsc#1180827)
   - Update avahi-daemon-check-dns.sh from Debian. Our previous version
     relied on ifconfig, route, and init.d.
   - Add sudo to requires: used to drop privileges.

   This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-370=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      avahi-0.7-lp152.3.6.1
      avahi-autoipd-0.7-lp152.3.6.1
      avahi-autoipd-debuginfo-0.7-lp152.3.6.1
      avahi-compat-howl-devel-0.7-lp152.3.6.1
      avahi-compat-mDNSResponder-devel-0.7-lp152.3.6.1
      avahi-debuginfo-0.7-lp152.3.6.1
      avahi-debugsource-0.7-lp152.3.6.1
      avahi-glib2-debugsource-0.7-lp152.3.6.1
      avahi-utils-0.7-lp152.3.6.1
      avahi-utils-debuginfo-0.7-lp152.3.6.1
      avahi-utils-gtk-0.7-lp152.3.6.1
      avahi-utils-gtk-debuginfo-0.7-lp152.3.6.1
      libavahi-client3-0.7-lp152.3.6.1
      libavahi-client3-debuginfo-0.7-lp152.3.6.1
      libavahi-common3-0.7-lp152.3.6.1
      libavahi-common3-debuginfo-0.7-lp152.3.6.1
      libavahi-core7-0.7-lp152.3.6.1
      libavahi-core7-debuginfo-0.7-lp152.3.6.1
      libavahi-devel-0.7-lp152.3.6.1
      libavahi-glib-devel-0.7-lp152.3.6.1
      libavahi-glib1-0.7-lp152.3.6.1
      libavahi-glib1-debuginfo-0.7-lp152.3.6.1
      libavahi-gobject-devel-0.7-lp152.3.6.1
      libavahi-gobject0-0.7-lp152.3.6.1
      libavahi-gobject0-debuginfo-0.7-lp152.3.6.1
      libavahi-ui-gtk3-0-0.7-lp152.3.6.1
      libavahi-ui-gtk3-0-debuginfo-0.7-lp152.3.6.1
      libavahi-ui0-0.7-lp152.3.6.1
      libavahi-ui0-debuginfo-0.7-lp152.3.6.1
      libdns_sd-0.7-lp152.3.6.1
      libdns_sd-debuginfo-0.7-lp152.3.6.1
      libhowl0-0.7-lp152.3.6.1
      libhowl0-debuginfo-0.7-lp152.3.6.1
      python3-avahi-0.7-lp152.3.6.1
      python3-avahi-gtk-0.7-lp152.3.6.1
      typelib-1_0-Avahi-0_6-0.7-lp152.3.6.1

   - openSUSE Leap 15.2 (noarch):

      avahi-lang-0.7-lp152.3.6.1

   - openSUSE Leap 15.2 (x86_64):

      avahi-32bit-debuginfo-0.7-lp152.3.6.1
      avahi-mono-0.7-lp152.3.6.1
      avahi-qt4-debugsource-0.7-lp152.3.6.1
      libavahi-client3-32bit-0.7-lp152.3.6.1
      libavahi-client3-32bit-debuginfo-0.7-lp152.3.6.1
      libavahi-common3-32bit-0.7-lp152.3.6.1
      libavahi-common3-32bit-debuginfo-0.7-lp152.3.6.1
      libavahi-glib1-32bit-0.7-lp152.3.6.1
      libavahi-glib1-32bit-debuginfo-0.7-lp152.3.6.1
      libavahi-qt4-1-0.7-lp152.3.6.1
      libavahi-qt4-1-debuginfo-0.7-lp152.3.6.1
      libavahi-qt4-devel-0.7-lp152.3.6.1
      libdns_sd-32bit-0.7-lp152.3.6.1
      libdns_sd-32bit-debuginfo-0.7-lp152.3.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-26720.html
   https://bugzilla.suse.com/1180827