openSUSE Security Update: Security update for gnome-autoar
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0390-1
Rating:             moderate
References:         #1181930 
Cross-References:   CVE-2020-36241
CVSS scores:
                    CVE-2020-36241 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
                    CVE-2020-36241 (SUSE): 3.9 CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for gnome-autoar fixes the following issues:

   - CVE-2020-36241: Skip problematic files that might be extracted outside
     of the destination dir to prevent potential directory traversal
     (bsc#1181930).

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-390=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      gnome-autoar-debuginfo-0.2.3-lp152.4.3.1
      gnome-autoar-debugsource-0.2.3-lp152.4.3.1
      gnome-autoar-devel-0.2.3-lp152.4.3.1
      libgnome-autoar-0-0-0.2.3-lp152.4.3.1
      libgnome-autoar-0-0-debuginfo-0.2.3-lp152.4.3.1
      libgnome-autoar-gtk-0-0-0.2.3-lp152.4.3.1
      libgnome-autoar-gtk-0-0-debuginfo-0.2.3-lp152.4.3.1
      typelib-1_0-GnomeAutoar-0_1-0.2.3-lp152.4.3.1
      typelib-1_0-GnomeAutoarGtk-0_1-0.2.3-lp152.4.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-36241.html
   https://bugzilla.suse.com/1181930