openSUSE Security Update: Security update for openexr
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0536-1
Rating:             moderate
References:         #1184172 #1184173 #1184174 
Cross-References:   CVE-2021-3474 CVE-2021-3475 CVE-2021-3476
                   
CVSS scores:
                    CVE-2021-3474 (NVD) : 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-3474 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-3475 (NVD) : 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-3475 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-3476 (NVD) : 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-3476 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for openexr fixes the following issues:

   - CVE-2021-3474: Undefined-shift in
     Imf_2_5::FastHufDecoder::FastHufDecoder (bsc#1184174)
   - CVE-2021-3475: Integer-overflow in Imf_2_5::calculateNumTiles
     (bsc#1184173)
   - CVE-2021-3476: Undefined-shift in Imf_2_5::unpack14 (bsc#1184172)

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-536=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      libIlmImf-2_2-23-2.2.1-lp152.7.11.1
      libIlmImf-2_2-23-debuginfo-2.2.1-lp152.7.11.1
      libIlmImfUtil-2_2-23-2.2.1-lp152.7.11.1
      libIlmImfUtil-2_2-23-debuginfo-2.2.1-lp152.7.11.1
      openexr-2.2.1-lp152.7.11.1
      openexr-debuginfo-2.2.1-lp152.7.11.1
      openexr-debugsource-2.2.1-lp152.7.11.1
      openexr-devel-2.2.1-lp152.7.11.1
      openexr-doc-2.2.1-lp152.7.11.1

   - openSUSE Leap 15.2 (x86_64):

      libIlmImf-2_2-23-32bit-2.2.1-lp152.7.11.1
      libIlmImf-2_2-23-32bit-debuginfo-2.2.1-lp152.7.11.1
      libIlmImfUtil-2_2-23-32bit-2.2.1-lp152.7.11.1
      libIlmImfUtil-2_2-23-32bit-debuginfo-2.2.1-lp152.7.11.1


References:

   https://www.suse.com/security/cve/CVE-2021-3474.html
   https://www.suse.com/security/cve/CVE-2021-3475.html
   https://www.suse.com/security/cve/CVE-2021-3476.html
   https://bugzilla.suse.com/1184172
   https://bugzilla.suse.com/1184173
   https://bugzilla.suse.com/1184174