openSUSE Security Update: Security update for apache-commons-io
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0605-1
Rating:             moderate
References:         #1184755 
Cross-References:   CVE-2021-29425
CVSS scores:
                    CVE-2021-29425 (NVD) : 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
                    CVE-2021-29425 (SUSE): 4.3 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for apache-commons-io fixes the following issues:

   - CVE-2021-29425: Limited path traversal when invoking the method
     FileNameUtils.normalize with an improper input string (bsc#1184755)

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-605=1



Package List:

   - openSUSE Leap 15.2 (noarch):

      apache-commons-io-2.6-lp152.2.3.1
      apache-commons-io-javadoc-2.6-lp152.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2021-29425.html
   https://bugzilla.suse.com/1184755