openSUSE: 2021:0635-1 important: libnettle

Advisories


   openSUSE Security Update: Security update for libnettle
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0635-1
Rating:             important
References:         #1184401 
Cross-References:   CVE-2021-20305
CVSS scores:
                    CVE-2021-20305 (NVD) : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-20305 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for libnettle fixes the following issues:

   - CVE-2021-20305: Fixed the multiply function which was being called with
     out-of-range scalars (bsc#1184401).

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-635=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      libhogweed4-3.4.1-lp152.4.3.1
      libhogweed4-debuginfo-3.4.1-lp152.4.3.1
      libnettle-debugsource-3.4.1-lp152.4.3.1
      libnettle-devel-3.4.1-lp152.4.3.1
      libnettle6-3.4.1-lp152.4.3.1
      libnettle6-debuginfo-3.4.1-lp152.4.3.1
      nettle-3.4.1-lp152.4.3.1
      nettle-debuginfo-3.4.1-lp152.4.3.1

   - openSUSE Leap 15.2 (x86_64):

      libhogweed4-32bit-3.4.1-lp152.4.3.1
      libhogweed4-32bit-debuginfo-3.4.1-lp152.4.3.1
      libnettle-devel-32bit-3.4.1-lp152.4.3.1
      libnettle6-32bit-3.4.1-lp152.4.3.1
      libnettle6-32bit-debuginfo-3.4.1-lp152.4.3.1


References:

   https://www.suse.com/security/cve/CVE-2021-20305.html
   https://bugzilla.suse.com/1184401

openSUSE: 2021:0635-1 important: libnettle

April 30, 2021
An update that fixes one vulnerability is now available

Description

This update for libnettle fixes the following issues: - CVE-2021-20305: Fixed the multiply function which was being called with out-of-range scalars (bsc#1184401). This update was imported from the SUSE:SLE-15:Update update project.

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-635=1

Package List

- openSUSE Leap 15.2 (i586 x86_64): libhogweed4-3.4.1-lp152.4.3.1 libhogweed4-debuginfo-3.4.1-lp152.4.3.1 libnettle-debugsource-3.4.1-lp152.4.3.1 libnettle-devel-3.4.1-lp152.4.3.1 libnettle6-3.4.1-lp152.4.3.1 libnettle6-debuginfo-3.4.1-lp152.4.3.1 nettle-3.4.1-lp152.4.3.1 nettle-debuginfo-3.4.1-lp152.4.3.1 - openSUSE Leap 15.2 (x86_64): libhogweed4-32bit-3.4.1-lp152.4.3.1 libhogweed4-32bit-debuginfo-3.4.1-lp152.4.3.1 libnettle-devel-32bit-3.4.1-lp152.4.3.1 libnettle6-32bit-3.4.1-lp152.4.3.1 libnettle6-32bit-debuginfo-3.4.1-lp152.4.3.1

References

https://www.suse.com/security/cve/CVE-2021-20305.html https://bugzilla.suse.com/1184401

Severity
Announcement ID: openSUSE-SU-2021:0635-1
Rating: important
Affected Products: openSUSE Leap 15.2 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.