openSUSE Security Update: Security update for cifs-utils
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0639-1
Rating:             important
References:         #1152930 #1174477 #1183239 #1184815 
Cross-References:   CVE-2020-14342 CVE-2021-20208
CVSS scores:
                    CVE-2020-14342 (NVD) : 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2020-14342 (SUSE): 4.4 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
                    CVE-2021-20208 (NVD) : 6.1 CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:H/A:N
                    CVE-2021-20208 (SUSE): 6.1 CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:H/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that solves two vulnerabilities and has two fixes
   is now available.

Description:


   This update for cifs-utils fixes the following security issues:

   - CVE-2021-20208: Fixed a potential kerberos auth leak escaping from
     container. (bsc#1183239)
   - CVE-2020-14342: Fixed a shell command injection vulnerability in
     mount.cifs. (bsc#1174477)

   This update for cifs-utils fixes the following issues:

   - Solve invalid directory mounting. When attempting to change the current
     working directory into non-existing directories, mount.cifs crashes.
     (bsc#1152930)

   - Fixed a bug where it was no longer possible to mount CIFS filesystem
     after the last maintenance update. (bsc#1184815)

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-639=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      cifs-utils-6.9-lp152.2.3.1
      cifs-utils-debuginfo-6.9-lp152.2.3.1
      cifs-utils-debugsource-6.9-lp152.2.3.1
      cifs-utils-devel-6.9-lp152.2.3.1
      pam_cifscreds-6.9-lp152.2.3.1
      pam_cifscreds-debuginfo-6.9-lp152.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-14342.html
   https://www.suse.com/security/cve/CVE-2021-20208.html
   https://bugzilla.suse.com/1152930
   https://bugzilla.suse.com/1174477
   https://bugzilla.suse.com/1183239
   https://bugzilla.suse.com/1184815