openSUSE Security Update: Security update for openexr
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0670-1
Rating:             important
References:         #1184353 #1184354 #1184355 #1185216 #1185217 
                    
Cross-References:   CVE-2021-20296 CVE-2021-23215 CVE-2021-26260
                    CVE-2021-3477 CVE-2021-3479
CVSS scores:
                    CVE-2021-20296 (NVD) : 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-20296 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-23215 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-26260 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-3477 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2021-3477 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2021-3479 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2021-3479 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes 5 vulnerabilities is now available.

Description:

   This update for openexr fixes the following issues:

   - CVE-2021-23215: Fixed an integer-overflow in
     Imf_2_5:DwaCompressor:initializeBuffers (bsc#1185216).
   - CVE-2021-26260: Fixed an Integer-overflow in
     Imf_2_5:DwaCompressor:initializeBuffers (bsc#1185217).
   - CVE-2021-20296: Fixed a  Null Pointer dereference in
     Imf_2_5:hufUncompress (bsc#1184355).
   - CVE-2021-3477: Fixed a Heap-buffer-overflow in
     Imf_2_5::DeepTiledInputFile::readPixelSampleCounts (bsc#1184353).
   - CVE-2021-3479: Fixed an Out-of-memory caused by allocation of a very
     large buffer (bsc#1184354).

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-670=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      libIlmImf-2_2-23-2.2.1-lp152.7.14.1
      libIlmImf-2_2-23-debuginfo-2.2.1-lp152.7.14.1
      libIlmImfUtil-2_2-23-2.2.1-lp152.7.14.1
      libIlmImfUtil-2_2-23-debuginfo-2.2.1-lp152.7.14.1
      openexr-2.2.1-lp152.7.14.1
      openexr-debuginfo-2.2.1-lp152.7.14.1
      openexr-debugsource-2.2.1-lp152.7.14.1
      openexr-devel-2.2.1-lp152.7.14.1
      openexr-doc-2.2.1-lp152.7.14.1

   - openSUSE Leap 15.2 (x86_64):

      libIlmImf-2_2-23-32bit-2.2.1-lp152.7.14.1
      libIlmImf-2_2-23-32bit-debuginfo-2.2.1-lp152.7.14.1
      libIlmImfUtil-2_2-23-32bit-2.2.1-lp152.7.14.1
      libIlmImfUtil-2_2-23-32bit-debuginfo-2.2.1-lp152.7.14.1


References:

   https://www.suse.com/security/cve/CVE-2021-20296.html
   https://www.suse.com/security/cve/CVE-2021-23215.html
   https://www.suse.com/security/cve/CVE-2021-26260.html
   https://www.suse.com/security/cve/CVE-2021-3477.html
   https://www.suse.com/security/cve/CVE-2021-3479.html
   https://bugzilla.suse.com/1184353
   https://bugzilla.suse.com/1184354
   https://bugzilla.suse.com/1184355
   https://bugzilla.suse.com/1185216
   https://bugzilla.suse.com/1185217