openSUSE: 2021:0798-1 important: mpv | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for mpv
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0798-1
Rating:             important
References:         #1186230 
Cross-References:   CVE-2021-30145
CVSS scores:
                    CVE-2021-30145 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Backports SLE-15-SP2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for mpv fixes the following issues:

   - CVE-2021-30145: Fixed format string vulnerability allows user-assisted
     remote attackers to achieve code execution via a crafted m3u playlist
     file (boo#1186230)

   This update was imported from the openSUSE:Leap:15.2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP2:

      zypper in -t patch openSUSE-2021-798=1



Package List:

   - openSUSE Backports SLE-15-SP2 (aarch64 ppc64le s390x x86_64):

      libmpv1-0.32.0+git.20200301T004003.e7bab0025f-bp152.2.6.1
      mpv-0.32.0+git.20200301T004003.e7bab0025f-bp152.2.6.1
      mpv-devel-0.32.0+git.20200301T004003.e7bab0025f-bp152.2.6.1

   - openSUSE Backports SLE-15-SP2 (noarch):

      mpv-bash-completion-0.32.0+git.20200301T004003.e7bab0025f-bp152.2.6.1
      mpv-zsh-completion-0.32.0+git.20200301T004003.e7bab0025f-bp152.2.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-30145.html
   https://bugzilla.suse.com/1186230

openSUSE: 2021:0798-1 important: mpv

May 27, 2021
An update that fixes one vulnerability is now available

Description

This update for mpv fixes the following issues: - CVE-2021-30145: Fixed format string vulnerability allows user-assisted remote attackers to achieve code execution via a crafted m3u playlist file (boo#1186230) This update was imported from the openSUSE:Leap:15.2:Update update project.

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP2: zypper in -t patch openSUSE-2021-798=1

Package List

- openSUSE Backports SLE-15-SP2 (aarch64 ppc64le s390x x86_64): libmpv1-0.32.0+git.20200301T004003.e7bab0025f-bp152.2.6.1 mpv-0.32.0+git.20200301T004003.e7bab0025f-bp152.2.6.1 mpv-devel-0.32.0+git.20200301T004003.e7bab0025f-bp152.2.6.1 - openSUSE Backports SLE-15-SP2 (noarch): mpv-bash-completion-0.32.0+git.20200301T004003.e7bab0025f-bp152.2.6.1 mpv-zsh-completion-0.32.0+git.20200301T004003.e7bab0025f-bp152.2.6.1

References

https://www.suse.com/security/cve/CVE-2021-30145.html https://bugzilla.suse.com/1186230

Severity
Announcement ID: openSUSE-SU-2021:0798-1
Rating: important
Affected Products: openSUSE Backports SLE-15-SP2 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.