openSUSE: 2021:0940-1 moderate: bouncycastle | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for bouncycastle
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0940-1
Rating:             moderate
References:         #1186328 
Cross-References:   CVE-2020-15522
CVSS scores:
                    CVE-2020-15522 (NVD) : 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
                    CVE-2020-15522 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for bouncycastle fixes the following issues:

   - CVE-2020-15522: Fixed a timing issue within the EC math library
     (bsc#1186328).

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-940=1



Package List:

   - openSUSE Leap 15.2 (noarch):

      bouncycastle-1.64-lp152.2.3.1
      bouncycastle-javadoc-1.64-lp152.2.3.1
      bouncycastle-mail-1.64-lp152.2.3.1
      bouncycastle-pg-1.64-lp152.2.3.1
      bouncycastle-pkix-1.64-lp152.2.3.1
      bouncycastle-tls-1.64-lp152.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-15522.html
   https://bugzilla.suse.com/1186328

openSUSE: 2021:0940-1 moderate: bouncycastle

June 29, 2021
An update that fixes one vulnerability is now available

Description

This update for bouncycastle fixes the following issues: - CVE-2020-15522: Fixed a timing issue within the EC math library (bsc#1186328). This update was imported from the SUSE:SLE-15-SP2:Update update project.

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-940=1

Package List

- openSUSE Leap 15.2 (noarch): bouncycastle-1.64-lp152.2.3.1 bouncycastle-javadoc-1.64-lp152.2.3.1 bouncycastle-mail-1.64-lp152.2.3.1 bouncycastle-pg-1.64-lp152.2.3.1 bouncycastle-pkix-1.64-lp152.2.3.1 bouncycastle-tls-1.64-lp152.2.3.1

References

https://www.suse.com/security/cve/CVE-2020-15522.html https://bugzilla.suse.com/1186328

Severity
Announcement ID: openSUSE-SU-2021:0940-1
Rating: moderate
Affected Products: openSUSE Leap 15.2 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.