openSUSE Security Update: Security update for curl
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1088-1
Rating:             moderate
References:         #1188217 #1188218 #1188219 #1188220 
Cross-References:   CVE-2021-22922 CVE-2021-22923 CVE-2021-22924
                    CVE-2021-22925
CVSS scores:
                    CVE-2021-22922 (SUSE): 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
                    CVE-2021-22923 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
                    CVE-2021-22924 (SUSE): 5.4 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
                    CVE-2021-22925 (SUSE): 4.3 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes four vulnerabilities is now available.

Description:

   This update for curl fixes the following issues:

   - CVE-2021-22925: TELNET stack contents disclosure again. (bsc#1188220)
   - CVE-2021-22924: Bad connection reuse due to flawed path name checks.
     (bsc#1188219)
   - CVE-2021-22923: Insufficiently Protected Credentials. (bsc#1188218)
   - CVE-2021-22922: Wrong content via metalink not discarded. (bsc#1188217)

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1088=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      curl-7.66.0-lp152.3.21.1
      curl-debuginfo-7.66.0-lp152.3.21.1
      curl-debugsource-7.66.0-lp152.3.21.1
      curl-mini-7.66.0-lp152.3.21.1
      curl-mini-debuginfo-7.66.0-lp152.3.21.1
      curl-mini-debugsource-7.66.0-lp152.3.21.1
      libcurl-devel-7.66.0-lp152.3.21.1
      libcurl-mini-devel-7.66.0-lp152.3.21.1
      libcurl4-7.66.0-lp152.3.21.1
      libcurl4-debuginfo-7.66.0-lp152.3.21.1
      libcurl4-mini-7.66.0-lp152.3.21.1
      libcurl4-mini-debuginfo-7.66.0-lp152.3.21.1

   - openSUSE Leap 15.2 (x86_64):

      libcurl-devel-32bit-7.66.0-lp152.3.21.1
      libcurl4-32bit-7.66.0-lp152.3.21.1
      libcurl4-32bit-debuginfo-7.66.0-lp152.3.21.1


References:

   https://www.suse.com/security/cve/CVE-2021-22922.html
   https://www.suse.com/security/cve/CVE-2021-22923.html
   https://www.suse.com/security/cve/CVE-2021-22924.html
   https://www.suse.com/security/cve/CVE-2021-22925.html
   https://bugzilla.suse.com/1188217
   https://bugzilla.suse.com/1188218
   https://bugzilla.suse.com/1188219
   https://bugzilla.suse.com/1188220