openSUSE Security Update: Security update for libhts
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1177-1
Rating:             low
References:         #1187917 
Cross-References:   CVE-2020-36403
CVSS scores:
                    CVE-2020-36403 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.2
                    openSUSE Backports SLE-15-SP3
                    openSUSE Backports SLE-15-SP2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:


   This update of libhts fixes the following security issue:

   - CVE-2020-36403: Fixed an out-of-bounds write access in
     vcf_parse_format() (bsc#1187917)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1177=1

   - openSUSE Backports SLE-15-SP3:

      zypper in -t patch openSUSE-2021-1177=1

   - openSUSE Backports SLE-15-SP2:

      zypper in -t patch openSUSE-2021-1177=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      bgzip-1.10.2-lp152.2.4.1
      bgzip-debuginfo-1.10.2-lp152.2.4.1
      htsfile-1.10.2-lp152.2.4.1
      htsfile-debuginfo-1.10.2-lp152.2.4.1
      libhts-debugsource-1.10.2-lp152.2.4.1
      libhts-devel-1.10.2-lp152.2.4.1
      libhts3-1.10.2-lp152.2.4.1
      libhts3-debuginfo-1.10.2-lp152.2.4.1
      tabix-1.10.2-lp152.2.4.1
      tabix-debuginfo-1.10.2-lp152.2.4.1

   - openSUSE Backports SLE-15-SP3 (aarch64 ppc64le s390x x86_64):

      bgzip-1.10.2-bp153.2.5.1
      bgzip-debuginfo-1.10.2-bp153.2.5.1
      htsfile-1.10.2-bp153.2.5.1
      htsfile-debuginfo-1.10.2-bp153.2.5.1
      libhts-debugsource-1.10.2-bp153.2.5.1
      libhts-devel-1.10.2-bp153.2.5.1
      libhts3-1.10.2-bp153.2.5.1
      libhts3-debuginfo-1.10.2-bp153.2.5.1
      tabix-1.10.2-bp153.2.5.1
      tabix-debuginfo-1.10.2-bp153.2.5.1

   - openSUSE Backports SLE-15-SP3 (aarch64_ilp32):

      libhts-devel-64bit-1.10.2-bp153.2.5.1
      libhts3-64bit-1.10.2-bp153.2.5.1
      libhts3-64bit-debuginfo-1.10.2-bp153.2.5.1

   - openSUSE Backports SLE-15-SP2 (aarch64 ppc64le s390x x86_64):

      bgzip-1.10.2-bp152.2.4.1
      bgzip-debuginfo-1.10.2-bp152.2.4.1
      htsfile-1.10.2-bp152.2.4.1
      htsfile-debuginfo-1.10.2-bp152.2.4.1
      libhts-debugsource-1.10.2-bp152.2.4.1
      libhts-devel-1.10.2-bp152.2.4.1
      libhts3-1.10.2-bp152.2.4.1
      libhts3-debuginfo-1.10.2-bp152.2.4.1
      tabix-1.10.2-bp152.2.4.1
      tabix-debuginfo-1.10.2-bp152.2.4.1

   - openSUSE Backports SLE-15-SP2 (aarch64_ilp32):

      libhts-devel-64bit-1.10.2-bp152.2.4.1
      libhts3-64bit-1.10.2-bp152.2.4.1
      libhts3-64bit-debuginfo-1.10.2-bp152.2.4.1


References:

   https://www.suse.com/security/cve/CVE-2020-36403.html
   https://bugzilla.suse.com/1187917