openSUSE Security Update: Security update for MozillaFirefox
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1184-1
Rating:             important
References:         #1188891 SLE-18626 
Cross-References:   CVE-2021-29980 CVE-2021-29984 CVE-2021-29985
                    CVE-2021-29986 CVE-2021-29988 CVE-2021-29989
                   
CVSS scores:
                    CVE-2021-29980 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-29984 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-29985 (SUSE): 6.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
                    CVE-2021-29986 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-29988 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-29989 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes 6 vulnerabilities, contains one
   feature is now available.

Description:

   This update for MozillaFirefox fixes the following issues:

   Firefox Extended Support Release 78.13.0 ESR (MFSA 2021-34, bsc#1188891):

   - CVE-2021-29986: Race condition when resolving DNS names could have led
     to memory corruption
   - CVE-2021-29988: Memory corruption as a result of incorrect style
     treatment
   - CVE-2021-29984: Incorrect instruction reordering during JIT optimization
   - CVE-2021-29980: Uninitialized memory in a canvas object could have led
     to memory corruption
   - CVE-2021-29985: Use-after-free media channels
   - CVE-2021-29989: Memory safety bugs fixed in Firefox 91 and Firefox ESR
     78.13

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1184=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      MozillaFirefox-78.13.0-lp152.2.64.1
      MozillaFirefox-branding-upstream-78.13.0-lp152.2.64.1
      MozillaFirefox-buildsymbols-78.13.0-lp152.2.64.1
      MozillaFirefox-debuginfo-78.13.0-lp152.2.64.1
      MozillaFirefox-debugsource-78.13.0-lp152.2.64.1
      MozillaFirefox-devel-78.13.0-lp152.2.64.1
      MozillaFirefox-translations-common-78.13.0-lp152.2.64.1
      MozillaFirefox-translations-other-78.13.0-lp152.2.64.1


References:

   https://www.suse.com/security/cve/CVE-2021-29980.html
   https://www.suse.com/security/cve/CVE-2021-29984.html
   https://www.suse.com/security/cve/CVE-2021-29985.html
   https://www.suse.com/security/cve/CVE-2021-29986.html
   https://www.suse.com/security/cve/CVE-2021-29988.html
   https://www.suse.com/security/cve/CVE-2021-29989.html
   https://bugzilla.suse.com/1188891