openSUSE: 2021:1189-1 important: openssl-1_0_0 | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for openssl-1_0_0
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1189-1
Rating:             important
References:         #1189521 
Cross-References:   CVE-2021-3712
CVSS scores:
                    CVE-2021-3712 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for openssl-1_0_0 fixes the following issues:

   - CVE-2021-3712: a bug in the code for printing certificate details could
     lead to a buffer overrun that a malicious actor could exploit to crash
     the application, causing a denial-of-service attack. [bsc#1189521]

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1189=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      libopenssl-1_0_0-devel-1.0.2p-lp152.8.15.1
      libopenssl10-1.0.2p-lp152.8.15.1
      libopenssl10-debuginfo-1.0.2p-lp152.8.15.1
      libopenssl1_0_0-1.0.2p-lp152.8.15.1
      libopenssl1_0_0-debuginfo-1.0.2p-lp152.8.15.1
      libopenssl1_0_0-hmac-1.0.2p-lp152.8.15.1
      libopenssl1_0_0-steam-1.0.2p-lp152.8.15.1
      libopenssl1_0_0-steam-debuginfo-1.0.2p-lp152.8.15.1
      openssl-1_0_0-1.0.2p-lp152.8.15.1
      openssl-1_0_0-cavs-1.0.2p-lp152.8.15.1
      openssl-1_0_0-cavs-debuginfo-1.0.2p-lp152.8.15.1
      openssl-1_0_0-debuginfo-1.0.2p-lp152.8.15.1
      openssl-1_0_0-debugsource-1.0.2p-lp152.8.15.1

   - openSUSE Leap 15.2 (noarch):

      openssl-1_0_0-doc-1.0.2p-lp152.8.15.1

   - openSUSE Leap 15.2 (x86_64):

      libopenssl-1_0_0-devel-32bit-1.0.2p-lp152.8.15.1
      libopenssl1_0_0-32bit-1.0.2p-lp152.8.15.1
      libopenssl1_0_0-32bit-debuginfo-1.0.2p-lp152.8.15.1
      libopenssl1_0_0-hmac-32bit-1.0.2p-lp152.8.15.1
      libopenssl1_0_0-steam-32bit-1.0.2p-lp152.8.15.1
      libopenssl1_0_0-steam-32bit-debuginfo-1.0.2p-lp152.8.15.1


References:

   https://www.suse.com/security/cve/CVE-2021-3712.html
   https://bugzilla.suse.com/1189521

openSUSE: 2021:1189-1 important: openssl-1_0_0

August 25, 2021
An update that fixes one vulnerability is now available

Description

This update for openssl-1_0_0 fixes the following issues: - CVE-2021-3712: a bug in the code for printing certificate details could lead to a buffer overrun that a malicious actor could exploit to crash the application, causing a denial-of-service attack. [bsc#1189521] This update was imported from the SUSE:SLE-15:Update update project.

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-1189=1

Package List

- openSUSE Leap 15.2 (i586 x86_64): libopenssl-1_0_0-devel-1.0.2p-lp152.8.15.1 libopenssl10-1.0.2p-lp152.8.15.1 libopenssl10-debuginfo-1.0.2p-lp152.8.15.1 libopenssl1_0_0-1.0.2p-lp152.8.15.1 libopenssl1_0_0-debuginfo-1.0.2p-lp152.8.15.1 libopenssl1_0_0-hmac-1.0.2p-lp152.8.15.1 libopenssl1_0_0-steam-1.0.2p-lp152.8.15.1 libopenssl1_0_0-steam-debuginfo-1.0.2p-lp152.8.15.1 openssl-1_0_0-1.0.2p-lp152.8.15.1 openssl-1_0_0-cavs-1.0.2p-lp152.8.15.1 openssl-1_0_0-cavs-debuginfo-1.0.2p-lp152.8.15.1 openssl-1_0_0-debuginfo-1.0.2p-lp152.8.15.1 openssl-1_0_0-debugsource-1.0.2p-lp152.8.15.1 - openSUSE Leap 15.2 (noarch): openssl-1_0_0-doc-1.0.2p-lp152.8.15.1 - openSUSE Leap 15.2 (x86_64): libopenssl-1_0_0-devel-32bit-1.0.2p-lp152.8.15.1 libopenssl1_0_0-32bit-1.0.2p-lp152.8.15.1 libopenssl1_0_0-32bit-debuginfo-1.0.2p-lp152.8.15.1 libopenssl1_0_0-hmac-32bit-1.0.2p-lp152.8.15.1 libopenssl1_0_0-steam-32bit-1.0.2p-lp152.8.15.1 libopenssl1_0_0-steam-32bit-debuginfo-1.0.2p-lp152.8.15.1

References

https://www.suse.com/security/cve/CVE-2021-3712.html https://bugzilla.suse.com/1189521

Severity
Announcement ID: openSUSE-SU-2021:1189-1
Rating: important
Affected Products: openSUSE Leap 15.2 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.