openSUSE Security Update: Security update for libmspack
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1200-1
Rating:             moderate
References:         #1103032 
Cross-References:   CVE-2018-14679 CVE-2018-14681 CVE-2018-14682
                   
CVSS scores:
                    CVE-2018-14679 (NVD) : 6.5 CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2018-14679 (SUSE): 4.4 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
                    CVE-2018-14681 (NVD) : 8.8 CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2018-14681 (SUSE): 4.4 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
                    CVE-2018-14682 (NVD) : 8.8 CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2018-14682 (SUSE): 4.4 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for libmspack fixes the following issues:

   - CVE-2018-14681: Bad KWAJ file header extensions could cause a one or two
     byte overwrite. (bsc#1103032)
   - CVE-2018-14682: There is an off-by-one error in the TOLOWER() macro for
     CHM decompression. (bsc#1103032)
   - CVE-2018-14679: There is an off-by-one error in the CHM PMGI/PMGL chunk
     number validity checks, which could lead to denial of service.
     (bsc#1103032)

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1200=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      libmspack-debugsource-0.6-lp152.6.3.1
      libmspack-devel-0.6-lp152.6.3.1
      libmspack0-0.6-lp152.6.3.1
      libmspack0-debuginfo-0.6-lp152.6.3.1
      mspack-tools-0.6-lp152.6.3.1
      mspack-tools-debuginfo-0.6-lp152.6.3.1

   - openSUSE Leap 15.2 (x86_64):

      libmspack0-32bit-0.6-lp152.6.3.1
      libmspack0-32bit-debuginfo-0.6-lp152.6.3.1


References:

   https://www.suse.com/security/cve/CVE-2018-14679.html
   https://www.suse.com/security/cve/CVE-2018-14681.html
   https://www.suse.com/security/cve/CVE-2018-14682.html
   https://bugzilla.suse.com/1103032