openSUSE Security Update: Security update for gstreamer-plugins-good
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1230-1
Rating:             moderate
References:         #1184735 #1184739 
Cross-References:   CVE-2021-3497 CVE-2021-3498
CVSS scores:
                    CVE-2021-3497 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-3497 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-3498 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-3498 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for gstreamer-plugins-good fixes the following issues:

   - CVE-2021-3498: Matroskademux: initialize track context out parameter to
     NULL before parsing (bsc#1184735).
   - CVE-2021-3497: Matroskademux: Fix extraction of multichannel WavPack
     (bsc#1184739).

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1230=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      gstreamer-plugins-good-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-debuginfo-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-debugsource-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-doc-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-extra-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-extra-debuginfo-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-gtk-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-gtk-debuginfo-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-jack-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-jack-debuginfo-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-qtqml-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-qtqml-debuginfo-1.16.3-lp152.2.6.1

   - openSUSE Leap 15.2 (x86_64):

      gstreamer-plugins-good-32bit-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-32bit-debuginfo-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-extra-32bit-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-extra-32bit-debuginfo-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-jack-32bit-1.16.3-lp152.2.6.1
      gstreamer-plugins-good-jack-32bit-debuginfo-1.16.3-lp152.2.6.1

   - openSUSE Leap 15.2 (noarch):

      gstreamer-plugins-good-lang-1.16.3-lp152.2.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-3497.html
   https://www.suse.com/security/cve/CVE-2021-3498.html
   https://bugzilla.suse.com/1184735
   https://bugzilla.suse.com/1184739