openSUSE Security Update: Security update for libqt5-qtsvg
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1371-1
Rating:             moderate
References:         #1184783 
Cross-References:   CVE-2021-3481
CVSS scores:
                    CVE-2021-3481 (SUSE): 5.4 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for libqt5-qtsvg fixes the following issues:

   - CVE-2021-3481: Fixed an out of bounds read in function QRadialFetchSimd
     from crafted svg file. (bsc#1184783)

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1371=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      libQt5Svg5-5.12.7-lp152.2.3.1
      libQt5Svg5-debuginfo-5.12.7-lp152.2.3.1
      libqt5-qtsvg-debugsource-5.12.7-lp152.2.3.1
      libqt5-qtsvg-devel-5.12.7-lp152.2.3.1
      libqt5-qtsvg-examples-5.12.7-lp152.2.3.1
      libqt5-qtsvg-examples-debuginfo-5.12.7-lp152.2.3.1

   - openSUSE Leap 15.2 (noarch):

      libqt5-qtsvg-private-headers-devel-5.12.7-lp152.2.3.1

   - openSUSE Leap 15.2 (x86_64):

      libQt5Svg5-32bit-5.12.7-lp152.2.3.1
      libQt5Svg5-32bit-debuginfo-5.12.7-lp152.2.3.1
      libqt5-qtsvg-devel-32bit-5.12.7-lp152.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2021-3481.html
   https://bugzilla.suse.com/1184783