openSUSE Security Update: Security update for glibc
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1374-1
Rating:             moderate
References:         #1186489 #1187911 
Cross-References:   CVE-2021-33574 CVE-2021-35942
CVSS scores:
                    CVE-2021-33574 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-33574 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-35942 (SUSE): 5.1 CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for glibc fixes the following issues:

   - CVE-2021-35942: wordexp: handle overflow in positional parameter number
     (bsc#1187911)
   - CVE-2021-33574: Use __pthread_attr_copy in mq_notify (bsc#1186489)

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1374=1



Package List:

   - openSUSE Leap 15.2 (i586 i686 x86_64):

      glibc-2.26-lp152.26.9.1
      glibc-debuginfo-2.26-lp152.26.9.1
      glibc-debugsource-2.26-lp152.26.9.1
      glibc-devel-2.26-lp152.26.9.1
      glibc-devel-debuginfo-2.26-lp152.26.9.1
      glibc-devel-static-2.26-lp152.26.9.1
      glibc-locale-2.26-lp152.26.9.1
      glibc-locale-base-2.26-lp152.26.9.1
      glibc-locale-base-debuginfo-2.26-lp152.26.9.1
      glibc-profile-2.26-lp152.26.9.1

   - openSUSE Leap 15.2 (i586 x86_64):

      glibc-extra-2.26-lp152.26.9.1
      glibc-extra-debuginfo-2.26-lp152.26.9.1
      glibc-utils-2.26-lp152.26.9.1
      glibc-utils-debuginfo-2.26-lp152.26.9.1
      glibc-utils-src-debugsource-2.26-lp152.26.9.1
      nscd-2.26-lp152.26.9.1
      nscd-debuginfo-2.26-lp152.26.9.1

   - openSUSE Leap 15.2 (noarch):

      glibc-html-2.26-lp152.26.9.1
      glibc-i18ndata-2.26-lp152.26.9.1
      glibc-info-2.26-lp152.26.9.1

   - openSUSE Leap 15.2 (x86_64):

      glibc-32bit-2.26-lp152.26.9.1
      glibc-32bit-debuginfo-2.26-lp152.26.9.1
      glibc-devel-32bit-2.26-lp152.26.9.1
      glibc-devel-32bit-debuginfo-2.26-lp152.26.9.1
      glibc-devel-static-32bit-2.26-lp152.26.9.1
      glibc-locale-base-32bit-2.26-lp152.26.9.1
      glibc-locale-base-32bit-debuginfo-2.26-lp152.26.9.1
      glibc-profile-32bit-2.26-lp152.26.9.1
      glibc-utils-32bit-2.26-lp152.26.9.1
      glibc-utils-32bit-debuginfo-2.26-lp152.26.9.1


References:

   https://www.suse.com/security/cve/CVE-2021-33574.html
   https://www.suse.com/security/cve/CVE-2021-35942.html
   https://bugzilla.suse.com/1186489
   https://bugzilla.suse.com/1187911