openSUSE Security Update: Security update for opera
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1434-1
Rating:             important
References:         
Cross-References:   CVE-2021-37974 CVE-2021-37975 CVE-2021-37976
                    CVE-2021-37977 CVE-2021-37978 CVE-2021-37979
                    CVE-2021-37980
Affected Products:
                    openSUSE Leap 15.3:NonFree
______________________________________________________________________________

   An update that fixes 7 vulnerabilities is now available.

Description:

   This update for opera fixes the following issues:

   Opera was updated to version 80.0.4170.63

   - CHR-8612 Update chromium on desktop-stable-94-4170 to 94.0.4606.81
   - DNA-95434 Crash at opera::ThemesService::UpdateCurrentTheme()
   - The update to chromium 94.0.4606.81 fixes following issues:
     CVE-2021-37977, CVE-2021-37978, CVE-2021-37979, CVE-2021-37980

   Opera was updated to version 80.0.4170.40

   - CHR-8598 Update chromium on desktop-stable-94-4170 to 94.0.4606.71
   - DNA-95221 Emoji button stuck in address bar
   - DNA-95325 Make y.at navigations to be reported with page_views events
   - DNA-95327 Add ???Emojis??? context menu option in address bar field
   - DNA-95339 Add YAT emoji url suggestion to search?? dialog
   - DNA-95416 Remove emoji button from address bar
   - DNA-95439 Enable #yat-emoji-addresses on developer stream
   - DNA-95441 [Mac big sur] Emoji are not shown in address bar url
   - DNA-95514 Crash at resource_coordinator::TabLifecycleUnitSource
     ::TabLifecycleUnit::OnLifecycleUnitStateChanged(mojom::
     LifecycleUnitState, mojom::LifecycleUnitStateChangeReason)
   - DNA-95746 Enable #reader-mode everywhere
   - DNA-95865 Numbers are recognized as emojis
   - DNA-95866 Change Yat text in selection popup
   - DNA-95867 Show that buttons are clickable in selection popup
   - The update to chromium 94.0.4606.71 fixes following issues:
     CVE-2021-37974, CVE-2021-37975, CVE-2021-37976


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:NonFree:

      zypper in -t patch openSUSE-2021-1434=1



Package List:

   - openSUSE Leap 15.3:NonFree (x86_64):

      opera-80.0.4170.63-lp153.2.27.1


References:

   https://www.suse.com/security/cve/CVE-2021-37974.html
   https://www.suse.com/security/cve/CVE-2021-37975.html
   https://www.suse.com/security/cve/CVE-2021-37976.html
   https://www.suse.com/security/cve/CVE-2021-37977.html
   https://www.suse.com/security/cve/CVE-2021-37978.html
   https://www.suse.com/security/cve/CVE-2021-37979.html
   https://www.suse.com/security/cve/CVE-2021-37980.html