openSUSE Security Update: Security update for tomcat
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1490-1
Rating:             moderate
References:         #1188278 #1188279 #1190558 
Cross-References:   CVE-2021-30640 CVE-2021-33037 CVE-2021-41079
                   
CVSS scores:
                    CVE-2021-30640 (NVD) : 6.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N
                    CVE-2021-30640 (SUSE): 6.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N
                    CVE-2021-33037 (NVD) : 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
                    CVE-2021-33037 (SUSE): 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
                    CVE-2021-41079 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for tomcat fixes the following issues:

   - CVE-2021-30640: Escape parameters in JNDI Realm queries (bsc#1188279).
   - CVE-2021-33037: Process T-E header from both HTTP 1.0 and HTTP 1.1.
     clients (bsc#1188278).
   - CVE-2021-41079: Fixed a denial of service caused by an unexpected TLS
     packet (bsc#1190558).

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1490=1



Package List:

   - openSUSE Leap 15.2 (noarch):

      tomcat-9.0.36-lp152.2.25.1
      tomcat-admin-webapps-9.0.36-lp152.2.25.1
      tomcat-docs-webapp-9.0.36-lp152.2.25.1
      tomcat-el-3_0-api-9.0.36-lp152.2.25.1
      tomcat-embed-9.0.36-lp152.2.25.1
      tomcat-javadoc-9.0.36-lp152.2.25.1
      tomcat-jsp-2_3-api-9.0.36-lp152.2.25.1
      tomcat-jsvc-9.0.36-lp152.2.25.1
      tomcat-lib-9.0.36-lp152.2.25.1
      tomcat-servlet-4_0-api-9.0.36-lp152.2.25.1
      tomcat-webapps-9.0.36-lp152.2.25.1


References:

   https://www.suse.com/security/cve/CVE-2021-30640.html
   https://www.suse.com/security/cve/CVE-2021-33037.html
   https://www.suse.com/security/cve/CVE-2021-41079.html
   https://bugzilla.suse.com/1188278
   https://bugzilla.suse.com/1188279
   https://bugzilla.suse.com/1190558