openSUSE Security Update: Security update for gmp
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1569-1
Rating:             moderate
References:         #1192717 
Cross-References:   CVE-2021-43618
CVSS scores:
                    CVE-2021-43618 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-43618 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for gmp fixes the following issues:

   - CVE-2021-43618: Fixed buffer overflow via crafted input in mpz/inp_raw.c
     (bsc#1192717).

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1569=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      gmp-debugsource-6.1.2-lp152.6.6.1
      gmp-devel-6.1.2-lp152.6.6.1
      libgmp10-6.1.2-lp152.6.6.1
      libgmp10-debuginfo-6.1.2-lp152.6.6.1
      libgmpxx4-6.1.2-lp152.6.6.1
      libgmpxx4-debuginfo-6.1.2-lp152.6.6.1

   - openSUSE Leap 15.2 (x86_64):

      gmp-devel-32bit-6.1.2-lp152.6.6.1
      libgmp10-32bit-6.1.2-lp152.6.6.1
      libgmp10-32bit-debuginfo-6.1.2-lp152.6.6.1
      libgmpxx4-32bit-6.1.2-lp152.6.6.1
      libgmpxx4-32bit-debuginfo-6.1.2-lp152.6.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-43618.html
   https://bugzilla.suse.com/1192717