openSUSE: 2021:1601-1 important: log4j

Advisories


   openSUSE Security Update: Security update for log4j
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1601-1
Rating:             important
References:         #1193743 
Cross-References:   CVE-2021-44228 CVE-2021-45046
CVSS scores:
                    CVE-2021-44228 (NVD) : 10 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
                    CVE-2021-44228 (SUSE): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-45046 (NVD) : 3.7 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-45046 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for log4j fixes the following issue:

   - Previously published fixes for log4jshell turned out to be incomplete.
     Upstream has followed up on the original patch for CVE-2021-44228 with
     several additional changes (LOG4J2-3198, LOG4J2-3201, LOG4J2-3208, and
     LOG4J2-3211) that are included in this update. Since the totality of
     those patches is pretty much equivalent to an update to the latest
     version of log4j, we did update the package's tarball from version
     2.13.0 to 2.16.0 instead of trying to apply those patches to the old
     version. This change brings in a new dependency on "jakarta-servlet" and
     a version update of "disruptor". [bsc#1193743, CVE-2021-45046]

   This update was imported from SUSE:SLE-15-SP2:Update.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1601=1



Package List:

   - openSUSE Leap 15.2 (noarch):

      disruptor-3.4.4-lp152.2.3.1
      disruptor-javadoc-3.4.4-lp152.2.3.1
      jakarta-servlet-5.0.0-lp152.2.1
      jakarta-servlet-javadoc-5.0.0-lp152.2.1
      log4j-2.16.0-lp152.3.9.1
      log4j-javadoc-2.16.0-lp152.3.9.1
      log4j-jcl-2.16.0-lp152.3.9.1
      log4j-slf4j-2.16.0-lp152.3.9.1


References:

   https://www.suse.com/security/cve/CVE-2021-44228.html
   https://www.suse.com/security/cve/CVE-2021-45046.html
   https://bugzilla.suse.com/1193743

openSUSE: 2021:1601-1 important: log4j

December 20, 2021
An update that fixes two vulnerabilities is now available

Description

This update for log4j fixes the following issue: - Previously published fixes for log4jshell turned out to be incomplete. Upstream has followed up on the original patch for CVE-2021-44228 with several additional changes (LOG4J2-3198, LOG4J2-3201, LOG4J2-3208, and LOG4J2-3211) that are included in this update. Since the totality of those patches is pretty much equivalent to an update to the latest version of log4j, we did update the package's tarball from version 2.13.0 to 2.16.0 instead of trying to apply those patches to the old version. This change brings in a new dependency on "jakarta-servlet" and a version update of "disruptor". [bsc#1193743, CVE-2021-45046] This update was imported from SUSE:SLE-15-SP2:Update.

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-1601=1

Package List

- openSUSE Leap 15.2 (noarch): disruptor-3.4.4-lp152.2.3.1 disruptor-javadoc-3.4.4-lp152.2.3.1 jakarta-servlet-5.0.0-lp152.2.1 jakarta-servlet-javadoc-5.0.0-lp152.2.1 log4j-2.16.0-lp152.3.9.1 log4j-javadoc-2.16.0-lp152.3.9.1 log4j-jcl-2.16.0-lp152.3.9.1 log4j-slf4j-2.16.0-lp152.3.9.1

References

https://www.suse.com/security/cve/CVE-2021-44228.html https://www.suse.com/security/cve/CVE-2021-45046.html https://bugzilla.suse.com/1193743

Severity
Announcement ID: openSUSE-SU-2021:1601-1
Rating: important
Affected Products: openSUSE Leap 15.2 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.