openSUSE Security Update: Security update for go1.16
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1626-1
Rating:             moderate
References:         #1182345 #1193597 #1193598 
Cross-References:   CVE-2021-44716 CVE-2021-44717
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that solves two vulnerabilities and has one
   errata is now available.

Description:

   This update for go1.16 fixes the following issues:

   Updated to upstream version 1.16.12 to include security fixes to the
   compiler, syscall, runtime, the net/http, net/http/httptest, and time
   packages (bsc#1182345)

   - CVE-2021-44717: syscall: don't close fd 0 on ForkExec error
     (bsc#1193598).
   - CVE-2021-44716: net/https: limit growth of header canonicalization cache
     (bsc#1193597).

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1626=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      go1.16-1.16.12-lp152.20.1
      go1.16-doc-1.16.12-lp152.20.1
      go1.16-race-1.16.12-lp152.20.1


References:

   https://www.suse.com/security/cve/CVE-2021-44716.html
   https://www.suse.com/security/cve/CVE-2021-44717.html
   https://bugzilla.suse.com/1182345
   https://bugzilla.suse.com/1193597
   https://bugzilla.suse.com/1193598