openSUSE: 2021:1631-1 important: kafka | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for kafka
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1631-1
Rating:             important
References:         #1193662 
Cross-References:   CVE-2021-4104
CVSS scores:
                    CVE-2021-4104 (SUSE): 6.4 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Backports SLE-15-SP3
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:


   This security update of kafka fixes the following issue:

   - CVE-2021-4104: Remove JMSAppender from log4j jars during build to
     prevent bsc#1193662,


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP3:

      zypper in -t patch openSUSE-2021-1631=1



Package List:

   - openSUSE Backports SLE-15-SP3 (aarch64 i586 ppc64le s390x x86_64):

      kafka-source-2.1.0-bp153.2.3.1

   - openSUSE Backports SLE-15-SP3 (x86_64):

      kafka-kit-2.1.0-bp153.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2021-4104.html
   https://bugzilla.suse.com/1193662

openSUSE: 2021:1631-1 important: kafka

December 28, 2021
An update that fixes one vulnerability is now available

Description

This security update of kafka fixes the following issue: - CVE-2021-4104: Remove JMSAppender from log4j jars during build to prevent bsc#1193662,

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP3: zypper in -t patch openSUSE-2021-1631=1

Package List

- openSUSE Backports SLE-15-SP3 (aarch64 i586 ppc64le s390x x86_64): kafka-source-2.1.0-bp153.2.3.1 - openSUSE Backports SLE-15-SP3 (x86_64): kafka-kit-2.1.0-bp153.2.3.1

References

https://www.suse.com/security/cve/CVE-2021-4104.html https://bugzilla.suse.com/1193662

Severity
Announcement ID: openSUSE-SU-2021:1631-1
Rating: important
Affected Products: openSUSE Backports SLE-15-SP3 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.