openSUSE: 2021:2158-1 important: openexr | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for openexr
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:2158-1
Rating:             important
References:         #1187310 #1187395 
Cross-References:   CVE-2021-3598 CVE-2021-3605
CVSS scores:
                    CVE-2021-3598 (SUSE): 4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-3605 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for openexr fixes the following issues:

   - Fixed CVE-2021-3605 [bsc#1187395]: Heap buffer overflow in the
     rleUncompress function
   - Fixed CVE-2021-3598 [bsc#1187310]: Heap buffer overflow in
     Imf_3_1:CharPtrIO:readChars


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-2158=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libIlmImf-2_2-23-2.2.1-3.32.1
      libIlmImf-2_2-23-debuginfo-2.2.1-3.32.1
      libIlmImfUtil-2_2-23-2.2.1-3.32.1
      libIlmImfUtil-2_2-23-debuginfo-2.2.1-3.32.1
      openexr-2.2.1-3.32.1
      openexr-debuginfo-2.2.1-3.32.1
      openexr-debugsource-2.2.1-3.32.1
      openexr-devel-2.2.1-3.32.1
      openexr-doc-2.2.1-3.32.1

   - openSUSE Leap 15.3 (x86_64):

      libIlmImf-2_2-23-32bit-2.2.1-3.32.1
      libIlmImf-2_2-23-32bit-debuginfo-2.2.1-3.32.1
      libIlmImfUtil-2_2-23-32bit-2.2.1-3.32.1
      libIlmImfUtil-2_2-23-32bit-debuginfo-2.2.1-3.32.1


References:

   https://www.suse.com/security/cve/CVE-2021-3598.html
   https://www.suse.com/security/cve/CVE-2021-3605.html
   https://bugzilla.suse.com/1187310
   https://bugzilla.suse.com/1187395

openSUSE: 2021:2158-1 important: openexr

July 11, 2021
An update that fixes two vulnerabilities is now available

Description

This update for openexr fixes the following issues: - Fixed CVE-2021-3605 [bsc#1187395]: Heap buffer overflow in the rleUncompress function - Fixed CVE-2021-3598 [bsc#1187310]: Heap buffer overflow in Imf_3_1:CharPtrIO:readChars

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-2158=1

Package List

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): libIlmImf-2_2-23-2.2.1-3.32.1 libIlmImf-2_2-23-debuginfo-2.2.1-3.32.1 libIlmImfUtil-2_2-23-2.2.1-3.32.1 libIlmImfUtil-2_2-23-debuginfo-2.2.1-3.32.1 openexr-2.2.1-3.32.1 openexr-debuginfo-2.2.1-3.32.1 openexr-debugsource-2.2.1-3.32.1 openexr-devel-2.2.1-3.32.1 openexr-doc-2.2.1-3.32.1 - openSUSE Leap 15.3 (x86_64): libIlmImf-2_2-23-32bit-2.2.1-3.32.1 libIlmImf-2_2-23-32bit-debuginfo-2.2.1-3.32.1 libIlmImfUtil-2_2-23-32bit-2.2.1-3.32.1 libIlmImfUtil-2_2-23-32bit-debuginfo-2.2.1-3.32.1

References

https://www.suse.com/security/cve/CVE-2021-3598.html https://www.suse.com/security/cve/CVE-2021-3605.html https://bugzilla.suse.com/1187310 https://bugzilla.suse.com/1187395

Severity
Announcement ID: openSUSE-SU-2021:2158-1
Rating: important
Affected Products: openSUSE Leap 15.3 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.