openSUSE: 2021:2214-1 important: go1.15 | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for go1.15
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:2214-1
Rating:             important
References:         #1175132 #1186622 #1187443 #1187444 #1187445 
                    
Cross-References:   CVE-2021-33195 CVE-2021-33196 CVE-2021-33197
                    CVE-2021-33198
CVSS scores:
                    CVE-2021-33195 (SUSE): 6.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:N
                    CVE-2021-33196 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-33197 (SUSE): 3.7 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
                    CVE-2021-33198 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that solves four vulnerabilities and has one
   errata is now available.

Description:

   This update for go1.15 fixes the following issues:

   Update to 1.15.13.

   Includes these security fixes

   - CVE-2021-33195: net: Lookup functions may return invalid host names
     (bsc#1187443).
   - CVE-2021-33196: archive/zip: malformed archive may cause panic or memory
     exhaustion (bsc#1186622).
   - CVE-2021-33197: net/http/httputil: ReverseProxy forwards Connection
     headers if first one is empty (bsc#1187444)
   - CVE-2021-33198: math/big: (*Rat).SetString with
     "1.770p02041010010011001001" crashes with "makeslice: len out of range"
     (bsc#1187445).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-2214=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      go1.15-1.15.13-1.33.1
      go1.15-doc-1.15.13-1.33.1

   - openSUSE Leap 15.3 (aarch64 x86_64):

      go1.15-race-1.15.13-1.33.1


References:

   https://www.suse.com/security/cve/CVE-2021-33195.html
   https://www.suse.com/security/cve/CVE-2021-33196.html
   https://www.suse.com/security/cve/CVE-2021-33197.html
   https://www.suse.com/security/cve/CVE-2021-33198.html
   https://bugzilla.suse.com/1175132
   https://bugzilla.suse.com/1186622
   https://bugzilla.suse.com/1187443
   https://bugzilla.suse.com/1187444
   https://bugzilla.suse.com/1187445

openSUSE: 2021:2214-1 important: go1.15

June 30, 2021
An update that solves four vulnerabilities and has one errata is now available

Description

This update for go1.15 fixes the following issues: Update to 1.15.13. Includes these security fixes - CVE-2021-33195: net: Lookup functions may return invalid host names (bsc#1187443). - CVE-2021-33196: archive/zip: malformed archive may cause panic or memory exhaustion (bsc#1186622). - CVE-2021-33197: net/http/httputil: ReverseProxy forwards Connection headers if first one is empty (bsc#1187444) - CVE-2021-33198: math/big: (*Rat).SetString with "1.770p02041010010011001001" crashes with "makeslice: len out of range" (bsc#1187445).

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-2214=1

Package List

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): go1.15-1.15.13-1.33.1 go1.15-doc-1.15.13-1.33.1 - openSUSE Leap 15.3 (aarch64 x86_64): go1.15-race-1.15.13-1.33.1

References

https://www.suse.com/security/cve/CVE-2021-33195.html https://www.suse.com/security/cve/CVE-2021-33196.html https://www.suse.com/security/cve/CVE-2021-33197.html https://www.suse.com/security/cve/CVE-2021-33198.html https://bugzilla.suse.com/1175132 https://bugzilla.suse.com/1186622 https://bugzilla.suse.com/1187443 https://bugzilla.suse.com/1187444 https://bugzilla.suse.com/1187445

Severity
Announcement ID: openSUSE-SU-2021:2214-1
Rating: important
Affected Products: openSUSE Leap 15.3 ble.

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.