openSUSE Security Update: Security update for qemu
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:2442-1
Rating:             important
References:         #1187499 #1187529 #1187538 #1187539 
Cross-References:   CVE-2021-3582 CVE-2021-3607 CVE-2021-3608
                    CVE-2021-3611
CVSS scores:
                    CVE-2021-3582 (SUSE): 3.2 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:L
                    CVE-2021-3607 (SUSE): 3.2 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:L
                    CVE-2021-3608 (SUSE): 3.2 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:L
                    CVE-2021-3611 (SUSE): 5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes four vulnerabilities is now available.

Description:

   This update for qemu fixes the following issues:

   - CVE-2021-3582: Fix possible mremap overflow in the pvrdma (bsc#1187499)
   - CVE-2021-3607: Ensure correct input on ring init (bsc#1187539)
   - CVE-2021-3608: Fix the ring init error flow (bsc#1187538)
   - CVE-2021-3611: Fix intel-hda segmentation fault due to stack overflow
     (bsc#1187529)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-2442=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      qemu-5.2.0-23.1
      qemu-arm-5.2.0-23.1
      qemu-arm-debuginfo-5.2.0-23.1
      qemu-audio-alsa-5.2.0-23.1
      qemu-audio-alsa-debuginfo-5.2.0-23.1
      qemu-audio-pa-5.2.0-23.1
      qemu-audio-pa-debuginfo-5.2.0-23.1
      qemu-audio-spice-5.2.0-23.1
      qemu-audio-spice-debuginfo-5.2.0-23.1
      qemu-block-curl-5.2.0-23.1
      qemu-block-curl-debuginfo-5.2.0-23.1
      qemu-block-dmg-5.2.0-23.1
      qemu-block-dmg-debuginfo-5.2.0-23.1
      qemu-block-gluster-5.2.0-23.1
      qemu-block-gluster-debuginfo-5.2.0-23.1
      qemu-block-iscsi-5.2.0-23.1
      qemu-block-iscsi-debuginfo-5.2.0-23.1
      qemu-block-nfs-5.2.0-23.1
      qemu-block-nfs-debuginfo-5.2.0-23.1
      qemu-block-rbd-5.2.0-23.1
      qemu-block-rbd-debuginfo-5.2.0-23.1
      qemu-block-ssh-5.2.0-23.1
      qemu-block-ssh-debuginfo-5.2.0-23.1
      qemu-chardev-baum-5.2.0-23.1
      qemu-chardev-baum-debuginfo-5.2.0-23.1
      qemu-chardev-spice-5.2.0-23.1
      qemu-chardev-spice-debuginfo-5.2.0-23.1
      qemu-debuginfo-5.2.0-23.1
      qemu-debugsource-5.2.0-23.1
      qemu-extra-5.2.0-23.1
      qemu-extra-debuginfo-5.2.0-23.1
      qemu-guest-agent-5.2.0-23.1
      qemu-guest-agent-debuginfo-5.2.0-23.1
      qemu-hw-display-qxl-5.2.0-23.1
      qemu-hw-display-qxl-debuginfo-5.2.0-23.1
      qemu-hw-display-virtio-gpu-5.2.0-23.1
      qemu-hw-display-virtio-gpu-debuginfo-5.2.0-23.1
      qemu-hw-display-virtio-gpu-pci-5.2.0-23.1
      qemu-hw-display-virtio-gpu-pci-debuginfo-5.2.0-23.1
      qemu-hw-display-virtio-vga-5.2.0-23.1
      qemu-hw-display-virtio-vga-debuginfo-5.2.0-23.1
      qemu-hw-s390x-virtio-gpu-ccw-5.2.0-23.1
      qemu-hw-s390x-virtio-gpu-ccw-debuginfo-5.2.0-23.1
      qemu-hw-usb-redirect-5.2.0-23.1
      qemu-hw-usb-redirect-debuginfo-5.2.0-23.1
      qemu-hw-usb-smartcard-5.2.0-23.1
      qemu-hw-usb-smartcard-debuginfo-5.2.0-23.1
      qemu-ivshmem-tools-5.2.0-23.1
      qemu-ivshmem-tools-debuginfo-5.2.0-23.1
      qemu-ksm-5.2.0-23.1
      qemu-lang-5.2.0-23.1
      qemu-ppc-5.2.0-23.1
      qemu-ppc-debuginfo-5.2.0-23.1
      qemu-s390x-5.2.0-23.1
      qemu-s390x-debuginfo-5.2.0-23.1
      qemu-tools-5.2.0-23.1
      qemu-tools-debuginfo-5.2.0-23.1
      qemu-ui-curses-5.2.0-23.1
      qemu-ui-curses-debuginfo-5.2.0-23.1
      qemu-ui-gtk-5.2.0-23.1
      qemu-ui-gtk-debuginfo-5.2.0-23.1
      qemu-ui-opengl-5.2.0-23.1
      qemu-ui-opengl-debuginfo-5.2.0-23.1
      qemu-ui-spice-app-5.2.0-23.1
      qemu-ui-spice-app-debuginfo-5.2.0-23.1
      qemu-ui-spice-core-5.2.0-23.1
      qemu-ui-spice-core-debuginfo-5.2.0-23.1
      qemu-vhost-user-gpu-5.2.0-23.1
      qemu-vhost-user-gpu-debuginfo-5.2.0-23.1
      qemu-x86-5.2.0-23.1
      qemu-x86-debuginfo-5.2.0-23.1

   - openSUSE Leap 15.3 (s390x x86_64):

      qemu-kvm-5.2.0-23.1

   - openSUSE Leap 15.3 (noarch):

      qemu-ipxe-1.0.0+-23.1
      qemu-microvm-5.2.0-23.1
      qemu-seabios-1.14.0_0_g155821a-23.1
      qemu-sgabios-8-23.1
      qemu-skiboot-5.2.0-23.1
      qemu-vgabios-1.14.0_0_g155821a-23.1


References:

   https://www.suse.com/security/cve/CVE-2021-3582.html
   https://www.suse.com/security/cve/CVE-2021-3607.html
   https://www.suse.com/security/cve/CVE-2021-3608.html
   https://www.suse.com/security/cve/CVE-2021-3611.html
   https://bugzilla.suse.com/1187499
   https://bugzilla.suse.com/1187529
   https://bugzilla.suse.com/1187538
   https://bugzilla.suse.com/1187539