openSUSE Security Update: Security update for spice-vdagent
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:2614-1
Rating:             important
References:         #1173749 #1177780 #1177781 #1177782 #1177783 
                    
Cross-References:   CVE-2020-25650 CVE-2020-25651 CVE-2020-25652
                    CVE-2020-25653
CVSS scores:
                    CVE-2020-25650 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2020-25650 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2020-25651 (NVD) : 6.4 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:L
                    CVE-2020-25651 (SUSE): 6.4 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:H
                    CVE-2020-25652 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2020-25652 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2020-25653 (SUSE): 8.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that solves four vulnerabilities and has one
   errata is now available.

Description:

   This update for spice-vdagent fixes the following issues:

   - Update to version 0.21.0
   - CVE-2020-25650: memory DoS via arbitrary entries in `active_xfers` hash
     table (bsc#1177780)
   - CVE-2020-25651: possible file transfer DoS and information leak via
     `active_xfers` hash map (bsc#1177781)
   - CVE-2020-25652: possibility to exhaust file descriptors in `vdagentd`
     (bsc#1177782)
   - CVE-2020-25653: UNIX domain socket peer PID retrieved via `SO_PEERCRED`
     is subject to race condition (bsc#1177783)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-2614=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      spice-vdagent-0.21.0-3.3.1
      spice-vdagent-debuginfo-0.21.0-3.3.1
      spice-vdagent-debugsource-0.21.0-3.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-25650.html
   https://www.suse.com/security/cve/CVE-2020-25651.html
   https://www.suse.com/security/cve/CVE-2020-25652.html
   https://www.suse.com/security/cve/CVE-2020-25653.html
   https://bugzilla.suse.com/1173749
   https://bugzilla.suse.com/1177780
   https://bugzilla.suse.com/1177781
   https://bugzilla.suse.com/1177782
   https://bugzilla.suse.com/1177783