openSUSE: 2021:2800-1 important: krb5 | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for krb5
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:2800-1
Rating:             important
References:         #1188571 
Cross-References:   CVE-2021-36222
CVSS scores:
                    CVE-2021-36222 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for krb5 fixes the following issues:

   - CVE-2021-36222: Fixed KDC null deref on bad encrypted challenge.
     (bsc#1188571)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-2800=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      krb5-1.16.3-3.21.1
      krb5-client-1.16.3-3.21.1
      krb5-client-debuginfo-1.16.3-3.21.1
      krb5-debuginfo-1.16.3-3.21.1
      krb5-debugsource-1.16.3-3.21.1
      krb5-devel-1.16.3-3.21.1
      krb5-mini-1.16.3-3.21.1
      krb5-mini-debuginfo-1.16.3-3.21.1
      krb5-mini-debugsource-1.16.3-3.21.1
      krb5-mini-devel-1.16.3-3.21.1
      krb5-plugin-kdb-ldap-1.16.3-3.21.1
      krb5-plugin-kdb-ldap-debuginfo-1.16.3-3.21.1
      krb5-plugin-preauth-otp-1.16.3-3.21.1
      krb5-plugin-preauth-otp-debuginfo-1.16.3-3.21.1
      krb5-plugin-preauth-pkinit-1.16.3-3.21.1
      krb5-plugin-preauth-pkinit-debuginfo-1.16.3-3.21.1
      krb5-server-1.16.3-3.21.1
      krb5-server-debuginfo-1.16.3-3.21.1

   - openSUSE Leap 15.3 (x86_64):

      krb5-32bit-1.16.3-3.21.1
      krb5-32bit-debuginfo-1.16.3-3.21.1
      krb5-devel-32bit-1.16.3-3.21.1


References:

   https://www.suse.com/security/cve/CVE-2021-36222.html
   https://bugzilla.suse.com/1188571

openSUSE: 2021:2800-1 important: krb5

August 20, 2021
An update that fixes one vulnerability is now available

Description

This update for krb5 fixes the following issues: - CVE-2021-36222: Fixed KDC null deref on bad encrypted challenge. (bsc#1188571)

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-2800=1

Package List

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): krb5-1.16.3-3.21.1 krb5-client-1.16.3-3.21.1 krb5-client-debuginfo-1.16.3-3.21.1 krb5-debuginfo-1.16.3-3.21.1 krb5-debugsource-1.16.3-3.21.1 krb5-devel-1.16.3-3.21.1 krb5-mini-1.16.3-3.21.1 krb5-mini-debuginfo-1.16.3-3.21.1 krb5-mini-debugsource-1.16.3-3.21.1 krb5-mini-devel-1.16.3-3.21.1 krb5-plugin-kdb-ldap-1.16.3-3.21.1 krb5-plugin-kdb-ldap-debuginfo-1.16.3-3.21.1 krb5-plugin-preauth-otp-1.16.3-3.21.1 krb5-plugin-preauth-otp-debuginfo-1.16.3-3.21.1 krb5-plugin-preauth-pkinit-1.16.3-3.21.1 krb5-plugin-preauth-pkinit-debuginfo-1.16.3-3.21.1 krb5-server-1.16.3-3.21.1 krb5-server-debuginfo-1.16.3-3.21.1 - openSUSE Leap 15.3 (x86_64): krb5-32bit-1.16.3-3.21.1 krb5-32bit-debuginfo-1.16.3-3.21.1 krb5-devel-32bit-1.16.3-3.21.1

References

https://www.suse.com/security/cve/CVE-2021-36222.html https://bugzilla.suse.com/1188571

Severity
Announcement ID: openSUSE-SU-2021:2800-1
Rating: important
Affected Products: openSUSE Leap 15.3 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.