openSUSE: 2021:2838-1 moderate: jetty-minimal | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for jetty-minimal
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:2838-1
Rating:             moderate
References:         #1188438 
Cross-References:   CVE-2021-34429
CVSS scores:
                    CVE-2021-34429 (NVD) : 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
                    CVE-2021-34429 (SUSE): 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for jetty-minimal fixes the following issues:

   - Update to version 9.4.43.v20210629
   - CVE-2021-34429: URIs can be crafted using some encoded characters to
     access the content of the WEB-INF directory and/or bypass some security
     constraints. (bsc#1188438)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-2838=1



Package List:

   - openSUSE Leap 15.3 (noarch):

      jetty-annotations-9.4.43-3.12.2
      jetty-client-9.4.43-3.12.2
      jetty-continuation-9.4.43-3.12.2
      jetty-http-9.4.43-3.12.2
      jetty-io-9.4.43-3.12.2
      jetty-jaas-9.4.43-3.12.2
      jetty-javax-websocket-client-impl-9.4.43-3.12.2
      jetty-javax-websocket-server-impl-9.4.43-3.12.2
      jetty-jmx-9.4.43-3.12.2
      jetty-jndi-9.4.43-3.12.2
      jetty-jsp-9.4.43-3.12.2
      jetty-minimal-javadoc-9.4.43-3.12.2
      jetty-openid-9.4.43-3.12.2
      jetty-plus-9.4.43-3.12.2
      jetty-proxy-9.4.43-3.12.2
      jetty-security-9.4.43-3.12.2
      jetty-server-9.4.43-3.12.2
      jetty-servlet-9.4.43-3.12.2
      jetty-util-9.4.43-3.12.2
      jetty-util-ajax-9.4.43-3.12.2
      jetty-webapp-9.4.43-3.12.2
      jetty-websocket-api-9.4.43-3.12.2
      jetty-websocket-client-9.4.43-3.12.2
      jetty-websocket-common-9.4.43-3.12.2
      jetty-websocket-javadoc-9.4.43-3.12.2
      jetty-websocket-server-9.4.43-3.12.2
      jetty-websocket-servlet-9.4.43-3.12.2
      jetty-xml-9.4.43-3.12.2


References:

   https://www.suse.com/security/cve/CVE-2021-34429.html
   https://bugzilla.suse.com/1188438

openSUSE: 2021:2838-1 moderate: jetty-minimal

August 25, 2021
An update that fixes one vulnerability is now available

Description

This update for jetty-minimal fixes the following issues: - Update to version 9.4.43.v20210629 - CVE-2021-34429: URIs can be crafted using some encoded characters to access the content of the WEB-INF directory and/or bypass some security constraints. (bsc#1188438)

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-2838=1

Package List

- openSUSE Leap 15.3 (noarch): jetty-annotations-9.4.43-3.12.2 jetty-client-9.4.43-3.12.2 jetty-continuation-9.4.43-3.12.2 jetty-http-9.4.43-3.12.2 jetty-io-9.4.43-3.12.2 jetty-jaas-9.4.43-3.12.2 jetty-javax-websocket-client-impl-9.4.43-3.12.2 jetty-javax-websocket-server-impl-9.4.43-3.12.2 jetty-jmx-9.4.43-3.12.2 jetty-jndi-9.4.43-3.12.2 jetty-jsp-9.4.43-3.12.2 jetty-minimal-javadoc-9.4.43-3.12.2 jetty-openid-9.4.43-3.12.2 jetty-plus-9.4.43-3.12.2 jetty-proxy-9.4.43-3.12.2 jetty-security-9.4.43-3.12.2 jetty-server-9.4.43-3.12.2 jetty-servlet-9.4.43-3.12.2 jetty-util-9.4.43-3.12.2 jetty-util-ajax-9.4.43-3.12.2 jetty-webapp-9.4.43-3.12.2 jetty-websocket-api-9.4.43-3.12.2 jetty-websocket-client-9.4.43-3.12.2 jetty-websocket-common-9.4.43-3.12.2 jetty-websocket-javadoc-9.4.43-3.12.2 jetty-websocket-server-9.4.43-3.12.2 jetty-websocket-servlet-9.4.43-3.12.2 jetty-xml-9.4.43-3.12.2

References

https://www.suse.com/security/cve/CVE-2021-34429.html https://bugzilla.suse.com/1188438

Severity
Announcement ID: openSUSE-SU-2021:2838-1
Rating: moderate
Affected Products: openSUSE Leap 15.3 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.