openSUSE: 2021:2875-1 important: nodejs12

Advisories


   openSUSE Security Update: Security update for nodejs12
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:2875-1
Rating:             important
References:         #1188881 #1188917 #1189368 #1189369 #1189370 
                    
Cross-References:   CVE-2021-22930 CVE-2021-22931 CVE-2021-22939
                    CVE-2021-22940 CVE-2021-3672
CVSS scores:
                    CVE-2021-22930 (SUSE): 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
                    CVE-2021-22931 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-22939 (SUSE): 4.3 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
                    CVE-2021-22940 (SUSE): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-3672 (SUSE): 8.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes 5 vulnerabilities is now available.

Description:

   This update for nodejs12 fixes the following issues:

   Update to 12.22.5:

   - CVE-2021-3672/CVE-2021-22931: Improper handling of untypical characters
     in domain names (bsc#1189370, bsc#1188881)
   - CVE-2021-22940: Use after free on close http2 on stream canceling
     (bsc#1189368)
   - CVE-2021-22939: Incomplete validation of rejectUnauthorized parameter
     (bsc#1189369)
   - CVE-2021-22930: http2: fixes use after free on close http2 on stream
     canceling (bsc#1188917)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-2875=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      nodejs12-12.22.5-4.19.1
      nodejs12-debuginfo-12.22.5-4.19.1
      nodejs12-debugsource-12.22.5-4.19.1
      nodejs12-devel-12.22.5-4.19.1
      npm12-12.22.5-4.19.1

   - openSUSE Leap 15.3 (noarch):

      nodejs12-docs-12.22.5-4.19.1


References:

   https://www.suse.com/security/cve/CVE-2021-22930.html
   https://www.suse.com/security/cve/CVE-2021-22931.html
   https://www.suse.com/security/cve/CVE-2021-22939.html
   https://www.suse.com/security/cve/CVE-2021-22940.html
   https://www.suse.com/security/cve/CVE-2021-3672.html
   https://bugzilla.suse.com/1188881
   https://bugzilla.suse.com/1188917
   https://bugzilla.suse.com/1189368
   https://bugzilla.suse.com/1189369
   https://bugzilla.suse.com/1189370

openSUSE: 2021:2875-1 important: nodejs12

August 30, 2021
An update that fixes 5 vulnerabilities is now available

Description

This update for nodejs12 fixes the following issues: Update to 12.22.5: - CVE-2021-3672/CVE-2021-22931: Improper handling of untypical characters in domain names (bsc#1189370, bsc#1188881) - CVE-2021-22940: Use after free on close http2 on stream canceling (bsc#1189368) - CVE-2021-22939: Incomplete validation of rejectUnauthorized parameter (bsc#1189369) - CVE-2021-22930: http2: fixes use after free on close http2 on stream canceling (bsc#1188917)

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-2875=1

Package List

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): nodejs12-12.22.5-4.19.1 nodejs12-debuginfo-12.22.5-4.19.1 nodejs12-debugsource-12.22.5-4.19.1 nodejs12-devel-12.22.5-4.19.1 npm12-12.22.5-4.19.1 - openSUSE Leap 15.3 (noarch): nodejs12-docs-12.22.5-4.19.1

References

https://www.suse.com/security/cve/CVE-2021-22930.html https://www.suse.com/security/cve/CVE-2021-22931.html https://www.suse.com/security/cve/CVE-2021-22939.html https://www.suse.com/security/cve/CVE-2021-22940.html https://www.suse.com/security/cve/CVE-2021-3672.html https://bugzilla.suse.com/1188881 https://bugzilla.suse.com/1188917 https://bugzilla.suse.com/1189368 https://bugzilla.suse.com/1189369 https://bugzilla.suse.com/1189370

Severity
Announcement ID: openSUSE-SU-2021:2875-1
Rating: important
Affected Products: openSUSE Leap 15.3 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.