openSUSE: 2021:2975-1 moderate: haproxy | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for haproxy
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:2975-1
Rating:             moderate
References:         #1189877 
Cross-References:   CVE-2021-40346
CVSS scores:
                    CVE-2021-40346 (SUSE): 5.4 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for haproxy fixes the following issues:

   - CVE-2021-40346: Fixed request smuggling vulnerability in HTX
     (bsc#1189877).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-2975=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      haproxy-2.0.14-11.11.1
      haproxy-debuginfo-2.0.14-11.11.1
      haproxy-debugsource-2.0.14-11.11.1


References:

   https://www.suse.com/security/cve/CVE-2021-40346.html
   https://bugzilla.suse.com/1189877

openSUSE: 2021:2975-1 moderate: haproxy

September 7, 2021
An update that fixes one vulnerability is now available

Description

This update for haproxy fixes the following issues: - CVE-2021-40346: Fixed request smuggling vulnerability in HTX (bsc#1189877).

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-2975=1

Package List

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): haproxy-2.0.14-11.11.1 haproxy-debuginfo-2.0.14-11.11.1 haproxy-debugsource-2.0.14-11.11.1

References

https://www.suse.com/security/cve/CVE-2021-40346.html https://bugzilla.suse.com/1189877

Severity
Announcement ID: openSUSE-SU-2021:2975-1
Rating: moderate
Affected Products: openSUSE Leap 15.3 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.