openSUSE Security Update: Security update for wireshark
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3017-1
Rating:             moderate
References:         #1188375 
Cross-References:   CVE-2021-22235
CVSS scores:
                    CVE-2021-22235 (SUSE): 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for wireshark fixes the following issues:

   - Update to Wireshark 3.4.7

   - CVE-2021-22235: Fixed DNP dissector crash (bsc#1188375).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3017=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libwireshark14-3.4.7-3.59.1
      libwireshark14-debuginfo-3.4.7-3.59.1
      libwiretap11-3.4.7-3.59.1
      libwiretap11-debuginfo-3.4.7-3.59.1
      libwsutil12-3.4.7-3.59.1
      libwsutil12-debuginfo-3.4.7-3.59.1
      wireshark-3.4.7-3.59.1
      wireshark-debuginfo-3.4.7-3.59.1
      wireshark-debugsource-3.4.7-3.59.1
      wireshark-devel-3.4.7-3.59.1
      wireshark-ui-qt-3.4.7-3.59.1
      wireshark-ui-qt-debuginfo-3.4.7-3.59.1


References:

   https://www.suse.com/security/cve/CVE-2021-22235.html
   https://bugzilla.suse.com/1188375