openSUSE Security Update: Security update for xen
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3140-1
Rating:             moderate
References:         #1027519 #1189632 
Cross-References:   CVE-2021-28701
CVSS scores:
                    CVE-2021-28701 (SUSE): 7.4 CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for xen fixes the following issues:

   - CVE-2021-28701: Fixed race condition in XENMAPSPACE_grant_table handling
     (XSA-384) (bsc#1189632).

   - Upstream bug fixes (bsc#1027519)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3140=1



Package List:

   - openSUSE Leap 15.3 (aarch64 x86_64):

      xen-4.14.2_06-3.12.1
      xen-debugsource-4.14.2_06-3.12.1
      xen-devel-4.14.2_06-3.12.1
      xen-doc-html-4.14.2_06-3.12.1
      xen-libs-4.14.2_06-3.12.1
      xen-libs-debuginfo-4.14.2_06-3.12.1
      xen-tools-4.14.2_06-3.12.1
      xen-tools-debuginfo-4.14.2_06-3.12.1
      xen-tools-domU-4.14.2_06-3.12.1
      xen-tools-domU-debuginfo-4.14.2_06-3.12.1

   - openSUSE Leap 15.3 (x86_64):

      xen-libs-32bit-4.14.2_06-3.12.1
      xen-libs-32bit-debuginfo-4.14.2_06-3.12.1

   - openSUSE Leap 15.3 (noarch):

      xen-tools-xendomains-wait-disk-4.14.2_06-3.12.1


References:

   https://www.suse.com/security/cve/CVE-2021-28701.html
   https://bugzilla.suse.com/1027519
   https://bugzilla.suse.com/1189632