openSUSE Security Update: Security update for curl
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3298-1
Rating:             moderate
References:         #1190373 #1190374 
Cross-References:   CVE-2021-22946 CVE-2021-22947
CVSS scores:
                    CVE-2021-22946 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
                    CVE-2021-22947 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for curl fixes the following issues:

   - CVE-2021-22947: Fixed STARTTLS protocol injection via MITM (bsc#1190374).
   - CVE-2021-22946: Fixed protocol downgrade required TLS bypassed
     (bsc#1190373).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3298=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      curl-7.66.0-4.27.1
      curl-debuginfo-7.66.0-4.27.1
      curl-debugsource-7.66.0-4.27.1
      libcurl-devel-7.66.0-4.27.1
      libcurl4-7.66.0-4.27.1
      libcurl4-debuginfo-7.66.0-4.27.1

   - openSUSE Leap 15.3 (x86_64):

      libcurl-devel-32bit-7.66.0-4.27.1
      libcurl4-32bit-7.66.0-4.27.1
      libcurl4-32bit-debuginfo-7.66.0-4.27.1


References:

   https://www.suse.com/security/cve/CVE-2021-22946.html
   https://www.suse.com/security/cve/CVE-2021-22947.html
   https://bugzilla.suse.com/1190373
   https://bugzilla.suse.com/1190374