openSUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3353-1
Rating:             important
References:         #1188697 #1190701 
Cross-References:   CVE-2021-21806 CVE-2021-30858
CVSS scores:
                    CVE-2021-21806 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-21806 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-30858 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-30858 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for webkit2gtk3 fixes the following issues:

   - Update to version 2.32.4
   - CVE-2021-30858: Fixed a security bug that could allow maliciously
     crafted web content to achieve arbitrary code execution. (bsc#1190701)
   - CVE-2021-21806: Fixed an exploitable use-after-free vulnerability via
     specially crafted HTML web page. (bsc#1188697)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3353=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libjavascriptcoregtk-4_0-18-2.32.4-12.3
      libjavascriptcoregtk-4_0-18-debuginfo-2.32.4-12.3
      libwebkit2gtk-4_0-37-2.32.4-12.3
      libwebkit2gtk-4_0-37-debuginfo-2.32.4-12.3
      typelib-1_0-JavaScriptCore-4_0-2.32.4-12.3
      typelib-1_0-WebKit2-4_0-2.32.4-12.3
      typelib-1_0-WebKit2WebExtension-4_0-2.32.4-12.3
      webkit-jsc-4-2.32.4-12.3
      webkit-jsc-4-debuginfo-2.32.4-12.3
      webkit2gtk-4_0-injected-bundles-2.32.4-12.3
      webkit2gtk-4_0-injected-bundles-debuginfo-2.32.4-12.3
      webkit2gtk3-debugsource-2.32.4-12.3
      webkit2gtk3-devel-2.32.4-12.3
      webkit2gtk3-minibrowser-2.32.4-12.3
      webkit2gtk3-minibrowser-debuginfo-2.32.4-12.3

   - openSUSE Leap 15.3 (noarch):

      libwebkit2gtk3-lang-2.32.4-12.3

   - openSUSE Leap 15.3 (x86_64):

      libjavascriptcoregtk-4_0-18-32bit-2.32.4-12.3
      libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.32.4-12.3
      libwebkit2gtk-4_0-37-32bit-2.32.4-12.3
      libwebkit2gtk-4_0-37-32bit-debuginfo-2.32.4-12.3


References:

   https://www.suse.com/security/cve/CVE-2021-21806.html
   https://www.suse.com/security/cve/CVE-2021-30858.html
   https://bugzilla.suse.com/1188697
   https://bugzilla.suse.com/1190701