openSUSE Security Update: Security update for postgresql14
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3759-1
Rating:             important
References:         #1191782 #1192516 
Cross-References:   CVE-2021-23214 CVE-2021-23222
CVSS scores:
                    CVE-2021-23214 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-23222 (SUSE): 3.7 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for postgresql14 fixes the following issues:

   - CVE-2021-23214: Make the server reject extraneous data after an SSL or
     GSS encryption handshake (bsc#1192516).
   - CVE-2021-23222: Make libpq reject extraneous data after an SSL or GSS
     encryption handshake (bsc#1192516).

   - Let rpmlint ignore shlib-policy-name-error (boo#1191782).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3759=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libecpg6-14.1-5.6.1
      libecpg6-debuginfo-14.1-5.6.1
      libpq5-14.1-5.6.1
      libpq5-debuginfo-14.1-5.6.1
      postgresql14-14.1-5.6.1
      postgresql14-contrib-14.1-5.6.1
      postgresql14-contrib-debuginfo-14.1-5.6.1
      postgresql14-debuginfo-14.1-5.6.1
      postgresql14-debugsource-14.1-5.6.1
      postgresql14-devel-14.1-5.6.1
      postgresql14-devel-debuginfo-14.1-5.6.1
      postgresql14-devel-mini-14.1-5.6.1
      postgresql14-devel-mini-debuginfo-14.1-5.6.1
      postgresql14-llvmjit-14.1-5.6.1
      postgresql14-llvmjit-debuginfo-14.1-5.6.1
      postgresql14-plperl-14.1-5.6.1
      postgresql14-plperl-debuginfo-14.1-5.6.1
      postgresql14-plpython-14.1-5.6.1
      postgresql14-plpython-debuginfo-14.1-5.6.1
      postgresql14-pltcl-14.1-5.6.1
      postgresql14-pltcl-debuginfo-14.1-5.6.1
      postgresql14-server-14.1-5.6.1
      postgresql14-server-debuginfo-14.1-5.6.1
      postgresql14-server-devel-14.1-5.6.1
      postgresql14-server-devel-debuginfo-14.1-5.6.1
      postgresql14-test-14.1-5.6.1

   - openSUSE Leap 15.3 (x86_64):

      libecpg6-32bit-14.1-5.6.1
      libecpg6-32bit-debuginfo-14.1-5.6.1
      libpq5-32bit-14.1-5.6.1
      libpq5-32bit-debuginfo-14.1-5.6.1

   - openSUSE Leap 15.3 (noarch):

      postgresql14-docs-14.1-5.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-23214.html
   https://www.suse.com/security/cve/CVE-2021-23222.html
   https://bugzilla.suse.com/1191782
   https://bugzilla.suse.com/1192516