openSUSE: 2021:3874-1 important: webkit2gtk3 | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3874-1
Rating:             important
References:         #1192063 
Cross-References:   CVE-2021-30846 CVE-2021-30851
CVSS scores:
                    CVE-2021-30846 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-30846 (SUSE): 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-30851 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-30851 (SUSE): 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for webkit2gtk3 fixes the following issues:

   - CVE-2021-30846: Fixed memory corruption issue that could lead to
     arbitrary code execution when processing maliciously crafted web content
     (bsc#1192063).
   - CVE-2021-30851: Fixed memory corruption vulnerability that could lead to
     arbitrary code execution when processing maliciously crafted web content
     (bsc#1192063).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3874=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libjavascriptcoregtk-4_0-18-2.34.1-18.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-18.1
      libwebkit2gtk-4_0-37-2.34.1-18.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-18.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-18.1
      typelib-1_0-WebKit2-4_0-2.34.1-18.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-18.1
      webkit-jsc-4-2.34.1-18.1
      webkit-jsc-4-debuginfo-2.34.1-18.1
      webkit2gtk-4_0-injected-bundles-2.34.1-18.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-18.1
      webkit2gtk3-debugsource-2.34.1-18.1
      webkit2gtk3-devel-2.34.1-18.1
      webkit2gtk3-minibrowser-2.34.1-18.1
      webkit2gtk3-minibrowser-debuginfo-2.34.1-18.1

   - openSUSE Leap 15.3 (noarch):

      libwebkit2gtk3-lang-2.34.1-18.1

   - openSUSE Leap 15.3 (x86_64):

      libjavascriptcoregtk-4_0-18-32bit-2.34.1-18.1
      libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.34.1-18.1
      libwebkit2gtk-4_0-37-32bit-2.34.1-18.1
      libwebkit2gtk-4_0-37-32bit-debuginfo-2.34.1-18.1


References:

   https://www.suse.com/security/cve/CVE-2021-30846.html
   https://www.suse.com/security/cve/CVE-2021-30851.html
   https://bugzilla.suse.com/1192063

openSUSE: 2021:3874-1 important: webkit2gtk3

December 2, 2021
An update that fixes two vulnerabilities is now available

Description

This update for webkit2gtk3 fixes the following issues: - CVE-2021-30846: Fixed memory corruption issue that could lead to arbitrary code execution when processing maliciously crafted web content (bsc#1192063). - CVE-2021-30851: Fixed memory corruption vulnerability that could lead to arbitrary code execution when processing maliciously crafted web content (bsc#1192063).

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-3874=1

Package List

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): libjavascriptcoregtk-4_0-18-2.34.1-18.1 libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-18.1 libwebkit2gtk-4_0-37-2.34.1-18.1 libwebkit2gtk-4_0-37-debuginfo-2.34.1-18.1 typelib-1_0-JavaScriptCore-4_0-2.34.1-18.1 typelib-1_0-WebKit2-4_0-2.34.1-18.1 typelib-1_0-WebKit2WebExtension-4_0-2.34.1-18.1 webkit-jsc-4-2.34.1-18.1 webkit-jsc-4-debuginfo-2.34.1-18.1 webkit2gtk-4_0-injected-bundles-2.34.1-18.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-18.1 webkit2gtk3-debugsource-2.34.1-18.1 webkit2gtk3-devel-2.34.1-18.1 webkit2gtk3-minibrowser-2.34.1-18.1 webkit2gtk3-minibrowser-debuginfo-2.34.1-18.1 - openSUSE Leap 15.3 (noarch): libwebkit2gtk3-lang-2.34.1-18.1 - openSUSE Leap 15.3 (x86_64): libjavascriptcoregtk-4_0-18-32bit-2.34.1-18.1 libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.34.1-18.1 libwebkit2gtk-4_0-37-32bit-2.34.1-18.1 libwebkit2gtk-4_0-37-32bit-debuginfo-2.34.1-18.1

References

https://www.suse.com/security/cve/CVE-2021-30846.html https://www.suse.com/security/cve/CVE-2021-30851.html https://bugzilla.suse.com/1192063

Severity
Announcement ID: openSUSE-SU-2021:3874-1
Rating: important
Affected Products: openSUSE Leap 15.3 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.