openSUSE: 2021:3968-1 moderate: xen | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for xen
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3968-1
Rating:             moderate
References:         #1027519 #1191363 #1192554 #1192557 #1192559 
                    
Cross-References:   CVE-2021-28702 CVE-2021-28704 CVE-2021-28705
                    CVE-2021-28706 CVE-2021-28707 CVE-2021-28708
                    CVE-2021-28709
CVSS scores:
                    CVE-2021-28702 (NVD) : 7.6 CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
                    CVE-2021-28704 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-28705 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-28705 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-28706 (NVD) : 8.6 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
                    CVE-2021-28706 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-28707 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-28708 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-28709 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes 7 vulnerabilities is now available.

Description:

   This update for xen fixes the following issues:

   - CVE-2021-28702: Fixed PCI devices with RMRRs not deassigned correctly
     (XSA-386) (bsc#1191363).
   - CVE-2021-28704, CVE-2021-28707, CVE-2021-28708: Fixed PoD operations on
     misaligned GFNs (XSA-388) (bsc#1192557).
   - CVE-2021-28705, CVE-2021-28709: Fixed issues with partially successful
     P2M updates on x86 (XSA-389) (bsc#1192559).
   - CVE-2021-28706: Fixed guests may exceed their designated memory limit
     (XSA-385) (bsc#1192554).

   - Update to Xen 4.14.3 bug fix release (bsc#1027519).


Special Instructions and Notes:

   Please reboot the system after installing this update.

Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3968=1



Package List:

   - openSUSE Leap 15.3 (aarch64 x86_64):

      xen-4.14.3_04-3.15.1
      xen-debugsource-4.14.3_04-3.15.1
      xen-devel-4.14.3_04-3.15.1
      xen-doc-html-4.14.3_04-3.15.1
      xen-libs-4.14.3_04-3.15.1
      xen-libs-debuginfo-4.14.3_04-3.15.1
      xen-tools-4.14.3_04-3.15.1
      xen-tools-debuginfo-4.14.3_04-3.15.1
      xen-tools-domU-4.14.3_04-3.15.1
      xen-tools-domU-debuginfo-4.14.3_04-3.15.1

   - openSUSE Leap 15.3 (x86_64):

      xen-libs-32bit-4.14.3_04-3.15.1
      xen-libs-32bit-debuginfo-4.14.3_04-3.15.1

   - openSUSE Leap 15.3 (noarch):

      xen-tools-xendomains-wait-disk-4.14.3_04-3.15.1


References:

   https://www.suse.com/security/cve/CVE-2021-28702.html
   https://www.suse.com/security/cve/CVE-2021-28704.html
   https://www.suse.com/security/cve/CVE-2021-28705.html
   https://www.suse.com/security/cve/CVE-2021-28706.html
   https://www.suse.com/security/cve/CVE-2021-28707.html
   https://www.suse.com/security/cve/CVE-2021-28708.html
   https://www.suse.com/security/cve/CVE-2021-28709.html
   https://bugzilla.suse.com/1027519
   https://bugzilla.suse.com/1191363
   https://bugzilla.suse.com/1192554
   https://bugzilla.suse.com/1192557
   https://bugzilla.suse.com/1192559

openSUSE: 2021:3968-1 moderate: xen

December 7, 2021
An update that fixes 7 vulnerabilities is now available

Description

This update for xen fixes the following issues: - CVE-2021-28702: Fixed PCI devices with RMRRs not deassigned correctly (XSA-386) (bsc#1191363). - CVE-2021-28704, CVE-2021-28707, CVE-2021-28708: Fixed PoD operations on misaligned GFNs (XSA-388) (bsc#1192557). - CVE-2021-28705, CVE-2021-28709: Fixed issues with partially successful P2M updates on x86 (XSA-389) (bsc#1192559). - CVE-2021-28706: Fixed guests may exceed their designated memory limit (XSA-385) (bsc#1192554). - Update to Xen 4.14.3 bug fix release (bsc#1027519). Special Instructions and Notes: Please reboot the system after installing this update.

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-3968=1

Package List

- openSUSE Leap 15.3 (aarch64 x86_64): xen-4.14.3_04-3.15.1 xen-debugsource-4.14.3_04-3.15.1 xen-devel-4.14.3_04-3.15.1 xen-doc-html-4.14.3_04-3.15.1 xen-libs-4.14.3_04-3.15.1 xen-libs-debuginfo-4.14.3_04-3.15.1 xen-tools-4.14.3_04-3.15.1 xen-tools-debuginfo-4.14.3_04-3.15.1 xen-tools-domU-4.14.3_04-3.15.1 xen-tools-domU-debuginfo-4.14.3_04-3.15.1 - openSUSE Leap 15.3 (x86_64): xen-libs-32bit-4.14.3_04-3.15.1 xen-libs-32bit-debuginfo-4.14.3_04-3.15.1 - openSUSE Leap 15.3 (noarch): xen-tools-xendomains-wait-disk-4.14.3_04-3.15.1

References

https://www.suse.com/security/cve/CVE-2021-28702.html https://www.suse.com/security/cve/CVE-2021-28704.html https://www.suse.com/security/cve/CVE-2021-28705.html https://www.suse.com/security/cve/CVE-2021-28706.html https://www.suse.com/security/cve/CVE-2021-28707.html https://www.suse.com/security/cve/CVE-2021-28708.html https://www.suse.com/security/cve/CVE-2021-28709.html https://bugzilla.suse.com/1027519 https://bugzilla.suse.com/1191363 https://bugzilla.suse.com/1192554 https://bugzilla.suse.com/1192557 https://bugzilla.suse.com/1192559

Severity
Announcement ID: openSUSE-SU-2021:3968-1
Rating: moderate
Affected Products: openSUSE Leap 15.3 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.