openSUSE: 2021:4169-1 moderate: go1.16

Advisories


   openSUSE Security Update: Security update for go1.16
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:4169-1
Rating:             moderate
References:         #1182345 #1193597 #1193598 
Cross-References:   CVE-2021-44716 CVE-2021-44717
Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that solves two vulnerabilities and has one
   errata is now available.

Description:

   This update for go1.16 fixes the following issues:

   Updated to upstream version 1.16.12 to include security fixes to the
   compiler, syscall, runtime, the net/http, net/http/httptest, and time
   packages (bsc#1182345)

   - CVE-2021-44717: syscall: don't close fd 0 on ForkExec error
     (bsc#1193598).
   - CVE-2021-44716: net/https: limit growth of header canonicalization cache
     (bsc#1193597).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-4169=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      go1.16-1.16.12-1.37.2
      go1.16-doc-1.16.12-1.37.2

   - openSUSE Leap 15.3 (aarch64 x86_64):

      go1.16-race-1.16.12-1.37.2


References:

   https://www.suse.com/security/cve/CVE-2021-44716.html
   https://www.suse.com/security/cve/CVE-2021-44717.html
   https://bugzilla.suse.com/1182345
   https://bugzilla.suse.com/1193597
   https://bugzilla.suse.com/1193598

openSUSE: 2021:4169-1 moderate: go1.16

December 23, 2021
An update that solves two vulnerabilities and has one errata is now available

Description

This update for go1.16 fixes the following issues: Updated to upstream version 1.16.12 to include security fixes to the compiler, syscall, runtime, the net/http, net/http/httptest, and time packages (bsc#1182345) - CVE-2021-44717: syscall: don't close fd 0 on ForkExec error (bsc#1193598). - CVE-2021-44716: net/https: limit growth of header canonicalization cache (bsc#1193597).

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-4169=1

Package List

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): go1.16-1.16.12-1.37.2 go1.16-doc-1.16.12-1.37.2 - openSUSE Leap 15.3 (aarch64 x86_64): go1.16-race-1.16.12-1.37.2

References

https://www.suse.com/security/cve/CVE-2021-44716.html https://www.suse.com/security/cve/CVE-2021-44717.html https://bugzilla.suse.com/1182345 https://bugzilla.suse.com/1193597 https://bugzilla.suse.com/1193598

Severity
Announcement ID: openSUSE-SU-2021:4169-1
Rating: moderate
Affected Products: openSUSE Leap 15.3 ble.

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.