openSUSE Security Update: Security update for jawn
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0011-1
Rating:             moderate
References:         #1194358 
Cross-References:   CVE-2022-21653
Affected Products:
                    openSUSE Backports SLE-15-SP3
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for jawn fixes the following issues:

   * CVE-2022-21653: DoS caused by a hash collision in SimpleFacade and
     MutableFacade (boo#1194358)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP3:

      zypper in -t patch openSUSE-2022-11=1



Package List:

   - openSUSE Backports SLE-15-SP3 (noarch):

      jawn-ast-0.14.1-bp153.2.3.1
      jawn-json4s-0.14.1-bp153.2.3.1
      jawn-parser-0.14.1-bp153.2.3.1
      jawn-util-0.14.1-bp153.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-21653.html
   https://bugzilla.suse.com/1194358