openSUSE Security Update: Security update for stb
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0018-1
Rating:             important
References:         #1191743 
Cross-References:   CVE-2021-42716
CVSS scores:
                    CVE-2021-42716 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Affected Products:
                    openSUSE Backports SLE-15-SP3
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for stb fixes the following issues:

   - CVE-2021-42716: fixed buffer overflow in stb_image PNM loader
     (boo#1191743)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP3:

      zypper in -t patch openSUSE-2022-18=1



Package List:

   - openSUSE Backports SLE-15-SP3 (noarch):

      stb-devel-2.32.1549563867.59e9702-bp153.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2021-42716.html
   https://bugzilla.suse.com/1191743