openSUSE Security Update: Security update for kafka
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0038-1
Rating:             important
References:         #1193662 #1194842 #1194843 #1194844 
Cross-References:   CVE-2021-4104 CVE-2022-23302 CVE-2022-23305
                    CVE-2022-23307
CVSS scores:
                    CVE-2021-4104 (NVD) : 7.5 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-4104 (SUSE): 6.4 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-23302 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-23302 (SUSE): 6.6 CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-23305 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-23305 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-23307 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Backports SLE-15-SP3
______________________________________________________________________________

   An update that fixes four vulnerabilities is now available.

Description:


   This update for kafka, kafka-kit fixes following issues:


   - Remove JDBCAppender, JMSSink, chainsaw from log4j jars during build to
     prevent bsc#1194842, CVE-2022-23302, bsc#1194843, CVE-2022-23305,
     bsc#1194844, CVE-2022-23307

   - Rebuild with kafka-kit change to Remove JMSAppender from log4j jars
     during build to prevent bsc#1193662, CVE-2021-4104


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP3:

      zypper in -t patch openSUSE-2022-38=1



Package List:

   - openSUSE Backports SLE-15-SP3 (aarch64 i586 ppc64le s390x x86_64):

      kafka-source-2.1.0-bp153.2.6.1

   - openSUSE Backports SLE-15-SP3 (x86_64):

      kafka-kit-2.1.0-bp153.2.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-4104.html
   https://www.suse.com/security/cve/CVE-2022-23302.html
   https://www.suse.com/security/cve/CVE-2022-23305.html
   https://www.suse.com/security/cve/CVE-2022-23307.html
   https://bugzilla.suse.com/1193662
   https://bugzilla.suse.com/1194842
   https://bugzilla.suse.com/1194843
   https://bugzilla.suse.com/1194844